LaTeX forum ⇒ DevelopmentTeXnicCenter 2.0 Alpha 2 (Build 1071) Issues

Information and discussion about the TeXnicCenter development. This is the place to go for TeXnicCenter core and wizard developers.
Knuffi
Posts: 25
Joined: Fri Oct 10, 2008 1:27 pm

TeXnicCenter 2.0 Alpha 2 (Build 1071) Issues

Postby Knuffi » Thu Dec 31, 2009 11:41 am

Thanks a lot for the new alpha version!

When installing Alpha 2 over Alpha 1, I get several times the message, that files which I want to overwrite are newer than the ones in the installation package.

Happy new year to all of you!

Izmi
Posts: 28
Joined: Thu Feb 26, 2009 6:14 pm

Postby Izmi » Mon Jan 04, 2010 10:57 am

1. Installing TXC 2.0 Alpha 2 in the Alpha 1 directory leads to problems: Setup complains that some files in the target directory are newer. (I used the files provided by the setup).

2. If TXC 2.0 Alpha 2 has been so installed, then it crashes on startup. Deleting HKCU\Software\ToolsCenter fixes the problem (while loosing customizations!).

3. Toolbars still flicker (refresh) during compilation (see: viewtopic.php?f=31&t=6487#p26104).

And a happy New Year!

Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Postby Sergiu » Mon Jan 04, 2010 12:26 pm

Izmi wrote:3. Toolbars still flicker (refresh) during compilation (see: viewtopic.php?f=31&t=6487#p26104).


I can't reproduce this problem on Windows 7. Which toolbars flicker exactly? All of them?

If possible start regedit.exe, navigate to HKEY_CURRENT_USER\Software\ToolsCenter\TeXnicCenterNT\Workspace, export it as a .reg file and attach it here.
TeXnicCenter Developer
http://www.texniccenter.org/

Izmi
Posts: 28
Joined: Thu Feb 26, 2009 6:14 pm

Postby Izmi » Mon Jan 04, 2010 12:42 pm

Hi Sergiu,

Thanks for your quick reply!

All toolbars with icons flicker when I compile a larger tex-file (compilation takes 20-30 seconds). I use Win 7 x64 (fully patched); I'll create a short movie with my digicam when I'm home to illustrate the issue.

Sergiu wrote:If possible start regedit.exe, navigate to HKEY_CURRENT_USER\Software\ToolsCenter\TeXnicCenterNT\Workspace, export it as a .reg file and attach it here.


From the current installation (which works) or the one which lead to crashes on startup? - I attached the current working one.
Attachments
txc-2a2_workspace.zip
(51.45 KiB) Downloaded 328 times

Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Postby Sergiu » Mon Jan 04, 2010 12:59 pm

This one's fine, thanks.
TeXnicCenter Developer
http://www.texniccenter.org/

Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Postby Sergiu » Mon Jan 04, 2010 2:35 pm

I could observe some flickering of toolbar grips on the left and right side of every toolbar when running Windows 7 x64, is that what you mean? On Windows 7 x86 the problem is hardly noticeable. Unfortunately this one is hard to debug, since TeXnicCenter doesn't update any toolbars while compilation. I guess the flickering is produced by the docking library we use.
TeXnicCenter Developer
http://www.texniccenter.org/

Izmi
Posts: 28
Joined: Thu Feb 26, 2009 6:14 pm

Postby Izmi » Mon Jan 04, 2010 2:41 pm

Sergiu wrote:I could observe some flickering of toolbar grips on the left and right side of every toolbar when running Windows 7 x64, is that what you mean?


Yes, this is what I mean (or more precisely: I believe that we mean the same).

Izmi
Posts: 28
Joined: Thu Feb 26, 2009 6:14 pm

Postby Izmi » Sat Jan 09, 2010 12:55 pm

A feature request: Add the functionality to set defaults for the creation of a new project (Using BibTeX? MakeIndex? Languages?).

Izmi
Posts: 28
Joined: Thu Feb 26, 2009 6:14 pm

Postby Izmi » Sun Jan 10, 2010 1:11 pm

Bug: After Windows resumes from hibernation, TXC 2a2 does sometimes not fully repaint its window (see screenshot).

The bug is not fully reproducible. The following steps trigger it sometimes:

1. Open TXC 2a2 with a project.
2. Let Windows go to standby.
3. Resume.
4. Repeat steps 2 and 3 some times.
5. Let Windows hibernate.
6. Resume.

Expected result: TXC 2a2 is in the state as before.
Observed result: TXC's window is not correctly painted. In the screenshot, the red area is of interest. I colored the area red. The actual color is white.
paint2a2-after_resume-20100110.jpg
paint2a2-after_resume-20100110.jpg (105.71 KiB) Viewed 8026 times

dellzhang
Posts: 1
Joined: Sun Jan 10, 2010 1:19 pm

Postby dellzhang » Sun Jan 10, 2010 2:02 pm

TeXnicCenter 2.0 Alpha has a number of improvements over the current Stable version that is already a great software tool. Thanks for your contribution to the world!

However, there is one serious problem that prevents me from switching to 2.0 Alpha: it crashes with the Visual C++ runtime error when a non-Unicode (such as ANSI) tex file (including template) is opened or saved. Choosing the UTF-16 (not just UTF-8) encoding avoids the crash, but MikTeX seems unable to compile such tex files.

I did some experiments and found the reason. In "Control Panel / Regional and Language Options", I have chosen to use the "Chinese (PRC)" code page for all non-Unicode programs, which is necessary for me as I still have many native Chinese programs on my machine. This bug is reproducible. Using the Chinese edition of "Visual C++ 2008 Redistributable Package" instead of the default one does not help. Using the English code page makes everything return to normal. Chinese (and many other Asian language) code pages are quite different with western language code pages as multiple bytes are required for each character. I suspect that some earlier reported "runtime error" bugs are also related to this.

The 1.0 Stable version does not have this problem.

I would be very grateful if the development team could fix it.


Return to “Development”

Who is online

Users browsing this forum: No registered users and 2 guests