LaTeX forum ⇒ Generalsync with Sumatra pdf config

General information and discussion about TeXnicCenter
willsh
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Re: sync with Sumatra pdf config

Postby willsh » Mon Jan 04, 2010 11:28 pm

localghost wrote:Got to the TXC Tutorials section where you can find a document with instructions how to make TXC and SumatraPDF work together.


Sorry, when I wrote:

I tried following the instructions carefully in the tutorial mentioned above...


I was referring to the document that you linked to. As I wrote before, I tried to follow those instructions exactly and received the error messages I quoted. My best guess is that there are some other settings I need to change or components I need to update which are not discussed in the tutorials.

Tags:

User avatar
localghost
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Mon Jan 04, 2010 11:35 pm

Oh, sorry. Should have read more carefully. The instructions in this tutorial work fine for me. You must have missed something. Make sure that you have inserted all necessary command line arguments for the compiler (especially the synctex option).
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

willsh
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Postby willsh » Tue Jan 05, 2010 12:12 am

Hmmm, I still can't find anything different.

One thing I'm not sure about is that in section 3 of the tutorial it says that it may be necessary to delete the configuration file in the Sumatra PDF folder and the .synctex file corresponding to my source file if I made a mistake. I don't seem to have either of these files (but that might just mean I haven't made certain mistakes?).

Also, there is one other error in the Output window: "Couldn't find input index file." Could that be part of the problem?

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Tue Jan 05, 2010 11:29 pm

Do you have the -synctex=-1 option in your latex command line?

willsh
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Postby willsh » Tue Jan 05, 2010 11:44 pm

This is what I have in the "Command line arguments to pass to the compiler" input box:

  1. -synctex=-1 -interaction=nonstopmode "%pm"

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Thu Jan 07, 2010 9:19 pm

willsh wrote:This is what I have in the "Command line arguments to pass to the compiler" input box:

  1. -synctex=-1 -interaction=nonstopmode "%pm"

That should be ok. Do you have an up-to-date version of sumatrapdf?

willsh
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Postby willsh » Thu Jan 07, 2010 9:26 pm

Yeah, I just downloaded TeXnicCenter and Sumatra this week so they are both the latest versions (Sumatra is v 1.0.1).

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Fri Jan 08, 2010 5:14 pm

This is strange... Maybe you should give all the details of your build profile (you can get screen captures).

willsh
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Postby willsh » Fri Jan 08, 2010 5:31 pm

Okay, hopefully this works.
Attachments
viewer.PNG
Build profile - viewer
viewer.PNG (25.33 KiB) Viewed 5514 times
postprocessor.PNG
Build profile - postprocessor
postprocessor.PNG (22.56 KiB) Viewed 5514 times
latex.PNG
Build profile - LaTeX
latex.PNG (28.94 KiB) Viewed 5514 times

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Fri Jan 08, 2010 7:57 pm

This should work... What is your inverse search command (the argument in the line "sumatrapdf,exe -inv..." that we can't see in your first image)?

And are you sure that your pdf compiles fine? This could happen if no pdf is produced.


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests