LaTeX forum ⇒ GeneralRuntime error when running TeXnicCenter and JabRef Topic is solved

General information and discussion about TeXnicCenter
snorre
Posts: 3
Joined: Mon Jun 25, 2007 9:15 am

Runtime error when running TeXnicCenter and JabRef

Postby snorre » Mon Jun 25, 2007 9:32 am

Lately, after doing an update of JabRef or Java (I don't remember which), I get an error message saying:

Microsoft Visual C++ Runtime Library
Runtime Error!
Program: C:\...\TEXCNTR.EXE
This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

when I run TeXnicCenter and JabRef at the same time. Then TeXnicCenter closes.
I run TeXnicCenter 1 Beta 7.01 -unstable ('Greengrass') and JabRef 2.2

What is causing this error, and what can I do to avoid it?
Thanks!

snorre
Posts: 3
Joined: Mon Jun 25, 2007 9:15 am

Postby snorre » Sun Jul 15, 2007 1:07 pm

Problem solved, reason still unknown.

In TeXnixCenter I disabled the "save automatic" option. Problem has not occurred since.

chris2u2
Posts: 5
Joined: Tue Aug 14, 2007 8:05 am

Postby chris2u2 » Tue Aug 14, 2007 8:11 am

It's definitely the update of JabRef! I had the same problem...

Switching back on JabRef is a pain though as the new JabRef-Version uses a new file format that's not backwards compatible ('"file" changed to "pdf", etc.)

However, I found a rather strange workaround:

Start TeXnicCenter first - then JabRef!

Then the error doesn't occur...

snorre
Posts: 3
Joined: Mon Jun 25, 2007 9:15 am

Postby snorre » Fri Aug 17, 2007 3:46 pm

It turns out I still have the problem, but I have discovered that the problem only occurs when both JabRef and TeXnicCenter are accessing the bib-file.

e.g. if the bib-file is opened in JabRef and the whole project is opened in TeXnicCenter (including the bib-file).

If only the tex-file is opened, not the whole project, the problem does not occur.

If, as suggested by chris2u2, the project is opened in TeXnicCenter first and later the bib-file is opened in JabRef everything works fine until I save the project in TeXnicCenter. Then it crashes.

So for the time being the "solution" to the problem is:
-Open the bib-file in JabRef
-Open the tex-file in TeXnicCenter
-Write the tex-file
when building project:
-Close JabRef
-Open and build project in TeXnicCenter

My current set of software:
TeXnicCenter 1 Beta 7.01 -unstable ('Greengrass')
JabRef 2.3b
Java version 6 update 2

Ciler
Posts: 1
Joined: Mon Aug 27, 2007 12:42 pm

Postby Ciler » Mon Aug 27, 2007 12:47 pm

Having to close jabref to compile is a bit of a hassle, imho. I accidently came up with another workaround that allows to have both a teXniccenter project (with automated saves) and jabref opened simultaneously.

  • Open Jabref first,
  • edit an entry, modify it and save (the review field is handy in order not to affect the actual bibliography).
  • Open the teXniccenter projexct

The major drawback of the method is that the bib file isn't automatically saved with the rest of the project by teXniccenter.

bjhenza
Posts: 1
Joined: Fri Jul 30, 2010 8:01 am

Postby bjhenza » Fri Jul 30, 2010 8:06 am

I am getting this error now with Jabref 2.6 and Texniccenter (not so) stable release 1.0 even though the previous posts on this topic are 3 years old.

Is anyone having the same problem. Thanks for these workarounds ciler and snorre but I think it is quite a pain to have to do this.

Help! (Anyone?)

guitarmanjon
Posts: 8
Joined: Tue Jul 12, 2011 12:39 pm

Postby guitarmanjon » Tue Jul 12, 2011 12:43 pm

Hi

This is still happening in 2011. I wonder if there are any developments on this runtime error.

I'm using TC 1.0 SRC 1 and Jabref 2.6.

I may have to resort back to manually editing my references!

jon

iolaizola
Posts: 1
Joined: Fri Dec 30, 2011 12:54 am

Postby iolaizola » Fri Dec 30, 2011 12:56 am

The problem is solved at least with Jabref v2.7.2. (Windows 7)

Ofboir
Posts: 7
Joined: Thu Oct 06, 2011 10:41 am

Postby Ofboir » Tue Mar 27, 2012 3:07 pm

Hi

I am using Windows 7, Texniccenter 1.0 SRC1 and Jabref 2.7.2, and I also have the problem.

I'm surprised that this problem, known for almost 5 years, is still not fixed ! Must be a tricky one ...

Cheers

baddisvali
Posts: 1
Joined: Mon Sep 03, 2012 12:02 pm

Postby baddisvali » Mon Sep 03, 2012 4:10 pm

I was also working on TeXnic center 1.0 SRC 1 and Jabref 2.7.2. I had Java V6.32 and everything work fine.

When I updated Java to V7 update 7, the run time error appeared.
I tried removing the new Java, but nothing worked.

I finally removed all previous Java installations, installed Java V7 update 7 again and removed Jabref 2.7.2 and installed 2.8.1 and that seems to have solved my problem.

As far as I see, this has something to do with Java and its compatibility to Jabref.


Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests