LaTeX forum ⇒ GeneralChem. structure drawing xymtex 4.03 doesn't run

General information and discussion about TeXnicCenter
a-candle
Posts: 2
Joined: Sat Jan 27, 2007 5:18 pm

Chem. structure drawing xymtex 4.03 doesn't run

Postby a-candle » Sat Jan 27, 2007 6:00 pm

Hello!

---Short Intro ---
On 05 Sept 2006 Shinsaku Fujita has released
"xymtex 4.03 for typesetting chemical structural formulas. An extension for stereochemistry according to postscript".
For more information see here: http://imt.chem.kit.ac.jp/fujita/fujita ... tml#xymtex

---My aim---
I have to draw stereochemical bonds instead of dotted and drawn through lines.

---Problem---
The actual version of MiKTex contains a old version of xymtex from 2001 which can't draw in a stereographical mode using ps-script. I have to use the actual version.

---My work ---
Searching and reading the manuals and FAQs. No hints were found.
Replacing the old files against the new files. These were in tree \tex\latex\xymtex.
Than the following .tex-file

\documentclass{article}
\usepackage{xymtex}
\begin{document}
\cyclohexanev{2SA==H;2SB==OH;3SA==OH;3SB==H}
\end{document}

doesn't run - but with the older version of xymtex!

--My questions---
Does this problem origin from MiKTex or by TeXNic?
Which links inside the packages are existing?


Thank very much for your suggestion!
Andreas
---
XyMTeX 7.01 beta
MiKTeX 2.5 from 24.01.07 (full installation)
Win XP SP2

Rémi
Posts: 9
Joined: Sun Jan 14, 2007 4:14 pm

Postby Rémi » Sat Jan 27, 2007 9:31 pm

What do you mean exactly by "doesn't run" ? What error ?
Sorry for my english. I'm french.

User avatar
Kris
Posts: 56
Joined: Sun Jan 14, 2007 4:04 pm

Postby Kris » Sat Jan 27, 2007 9:45 pm

Hi Andreas,

Sorry, but it is a coding-problem...You have to enable
the PS-mode of xymtex by calling xymtexps, please try this:

  1. \documentclass{article}
  2. \usepackage{xymtexps} % enables PS-mode
  3. \begin{document}
  4. \cyclohexanev{2SA==H;2SB==OH;3SA==OH;3SB==H}
  5. \end{document}

You can easily add the newest xymtex-package in the following way:

1 - create a new localtexmf-tree => c:\localtexmf\tex\latex
2 - decompress the newest xymtex-package into this path (c:\localtexmf\tex\latex\xymtex)
3 - adjust the MiKTeX-settings for path search (MiKTeX Settings => Roots) by adding c:\localtexmf
and move it before the original installation path (e.g. c:\texmf)

Now MiKTeX will use the newest version (installed in c:\localtexmf) ...

Regards
Kris

a-candle
Posts: 2
Joined: Sat Jan 27, 2007 5:18 pm

Postby a-candle » Sun Jan 28, 2007 1:09 pm

Hello Kris
Hello to all others

MiKTeX works properly now.

I've to apologize for losing the overview because of there are hints in the FAQ of MiKTeX under "maintanance".

I can announce it so : Because of the tons of manuals coming with TeX (I'm testing since two weekends) the MiKTeX background disappears from my sight.

Sorry for causing this little inconvenience.

Thank you very much for your help to my hurried starting up!

Now I will make the changeover to TeX. That's beyond question.

Sincerely yours
Andreas


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest