LaTeX forum ⇒ GeneralUnknown Error in TeXnicCenter

General information and discussion about TeXnicCenter
EbrithilBowser
Posts: 2
Joined: Thu Feb 20, 2014 4:00 pm

Unknown Error in TeXnicCenter

Postby EbrithilBowser » Thu Feb 20, 2014 4:10 pm

Hello,

I packaged TeXnicCenter 2.02 and MiKTeX 2.9 for our Company. Within the TeXnic-Package, I included the Registry-Keys for creating all of the Profiles (not sure if this is relevant for the problem) and granted user-access to "C:\Program Files (x86)\MiKTeX 2.9".

But now, when I install both programs on a users PC, and a user starts TeXnicCenter, she gets an "Unknown Error" without any further information everytime she opens a project or File via "File => Open". Everything works fine it she drag and drops the file into TeXnicCenter or klicks it in Windows Explorer and opens with TeXnic

I have no experience with LaTeX, because I am the Sysadmin and just try to package the Software, but I hope you can help me with the problem. If you need any further information, feel free to ask

Regards,
Bowser
Last edited by EbrithilBowser on Mon Feb 24, 2014 11:04 am, edited 1 time in total.

hugovdberg
Posts: 133
Joined: Sat Feb 25, 2012 6:12 pm

Postby hugovdberg » Thu Feb 20, 2014 4:29 pm

At the moment I do not have access to my Windows machine with TeXnicCenter, but as a former sysadmin myself I suspect you know the drill of debugging this sort of generic error messages.
  • Check logs: Are there any error messages in either TeXnicCenter's own logfiles or in Windows' Event Viewer?
  • Check user rights: Did you try to run the program yourself with administrator privileges, and does the error then still occur?
Ubuntu 13.10 + Tex Live 2013 + Texmaker / Windows 7 Pro + MikTex 2.9 + TexnicCenter / Android 4.3 + TexPortal + DroidEdit

EbrithilBowser
Posts: 2
Joined: Thu Feb 20, 2014 4:00 pm

Postby EbrithilBowser » Thu Feb 20, 2014 5:11 pm

Hello hugovdberg,

Where does TeXnicCenter place its logfiles?

̶w̶̶i̶̶t̶̶h̶̶ ̶̶a̶̶d̶̶m̶̶i̶̶n̶̶ ̶̶p̶̶r̶̶i̶̶v̶̶i̶̶l̶̶e̶̶g̶̶e̶̶s̶̶,̶̶ ̶̶t̶̶h̶̶e̶̶ ̶̶p̶̶r̶̶o̶̶b̶̶l̶̶e̶̶m̶̶ ̶̶d̶̶o̶̶e̶̶s̶̶n̶'̶t̶̶ ̶̶o̶̶c̶̶c̶̶u̶̶r̶̶.̶
However, the user has read/write permission on the MiKTeX Installation Folder and on the project files

Didn't think about the Windows Event Viewer. It shows an error message including C:\Windows\system32\KERNELBASE.dll

"Faulting application TeXnicCenter.exe, version 2.2.0.0, time stamp 0x524740c9, faulting module KERNELBASE.dll, version 6.1.7601.18229, time stamp 0x51fb1677, exception code 0xe06d7363, fault offset 0x000000000000940d, process id 0x13ac, application start time 0x01cf2e3c18f39928".

I found something about a similar error in the Ticket-System of TeXnicCenter, but they say it should be gone with a newer version. And since the Ticket is from 2012 and I have the newest version, this doesn't really help
http://sourceforge.net/p/texniccenter/u ... orts/1238/

Edit: Did a few tests, also on other machines. It seems the problem only occurs on one machine, with every user (even if he is local admin), what leads me to the conclusion that the Kernelbase.dll on this machine is somehow corrupted. I compared it with the Kernelbase.dll of another PC on which TeXnicCenter is working, but they seem to be indentical

Edit2: I now reinstalled the machine, now everything works fine


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests