LaTeX forum ⇒ GeneralTeXnicCenter 2 Beta with Sumatra PDF Topic is solved

General information and discussion about TeXnicCenter
ralfinho
Posts: 6
Joined: Fri Jan 04, 2013 12:15 pm

TeXnicCenter 2 Beta with Sumatra PDF  Topic is solved

Postby ralfinho » Fri Jan 04, 2013 12:53 pm

My Operating System is Windows 7 64bit. I have installed MikTex 2.94503 and TeXnicCenter 2 Beta. If necessary, please adjust the given paths. My settings are:

Start TeXnicCenter.
Klick on:
Build- Define Outout Profiles

Profile:
LaTex - PDF


(La)Tex:
Klick on:
Run (La)Tex in this profile

Path to the (La)Tex compiler:
C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe


Command line arguments to pass to the compiler:
-synctex=-1 -max-print-line=120 -interaction=nonstopmode "%wm"

Command line arguments to pass to bibtex:
"%tm"

Command line arguments to pass to MakeIndex:
"%tm.idx" -t "%tm.ilg" -o "%tm.ind"



Viewer:
Executable path:
C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Programme\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto(’%f’,’%l’)]’\""
- this is all one line. After Programme there is no empty space

View project's output:
Klick on DDE command
Command: [Open("%bm.pdf",0,1,1)]

Forward search:
Klick on DDE commando
Command: [ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]

Close document before running (La)Tex:
Klick on Do not close

Open Sumatra PDf
Einstellungen - Optionen
The line under 'Befehlszeile für die Inversuche setzen' must read:
"C:\Programme\TeXnicCenter\TeXnicCenter.exe" /ddecmd "[goto(’%f’,’%l’)]’"

With this settings I have got no more errors or warnings and the forward search works. I hope the same is true for your computer. Greets

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 9434
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Fri Jan 04, 2013 3:09 pm

Thank you for the description!

Is it possible to change the language for Sumatra PDF without re-installation? If yes, perhaps you could edit and change/add the English version of the Sumatra PDF settings at the end of your post. I don't have it on the computer I'm currently using, which runs Linux.

Stefan
Site admin

ralfinho
Posts: 6
Joined: Fri Jan 04, 2013 12:15 pm

Postby ralfinho » Sun Jan 06, 2013 2:43 pm

Of course,
Open Sumatra PDF
Settings - Options
The line under'Set inverse search command line' must read:
"C:\Programme\TeXnicCenter\TeXnicCenter.exe" /ddecmd "[goto(’%f’,’%l’)]’"

I was just a little bit lazy.

jac
Posts: 1
Joined: Sun Jun 09, 2013 3:27 pm

Postby jac » Sun Jun 09, 2013 3:45 pm

Dear guys,

I have a questions here. Taking a careful look on both commandlines containing the GoTo command:

/ddecmd \"[goto('%f','%l')]'\"

There is a ' before the backslash at the end. What does the last ' mean?
It makes no difference leaving this symbol out.

Thanks in advance for helping me.

Cheers


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests