LaTeX forum ⇒ WinEdtWinEdt10.3 cannot compile the template of Journal of Advanced Mechanical Design, Systems, and Manufacturing Topic is solved

Information and discussion about WinEdt, a commercial integrated LaTeX environment for Windows
ouros
Posts: 2
Joined: Sat Oct 02, 2021 10:44 am

WinEdt10.3 cannot compile the template of Journal of Advanced Mechanical Design, Systems, and Manufacturing

Postby ouros » Sat Oct 02, 2021 10:48 am

I am writing a paper for the Journal of Advanced Mechanical Design, Systems, and Manufacturing currently, and I have a problem. My Winedt cannot compile the template.

Here is the log of the PDFTeXify:

Command Line: pdflatex.exe --interaction=errorstopmode --synctex=-1 "Journal_Tex_template_manual.tex"
Startup Folder: C:\Users\xumt\Desktop\english-template

This is pdfTeX, Version 3.141592653-2.6-1.40.22 (MiKTeX 21.2)
entering extended mode
(Journal_Tex_template_manual.tex
LaTeX2e <2020-10-01> patch level 4
L3 programming layer <2021-02-18> xparse <2020-03-03> (jsme-tj.cls
Document Class: jsme-tj 2013/08/08 ver.3.1 Showa-johoprocess
(D:\software\winedt10\Miktex\tex/latex/graphics\graphicx.sty
(D:\software\winedt10\Miktex\tex/latex/graphics\keyval.sty)
(D:\software\winedt10\Miktex\tex/latex/graphics\graphics.sty
(D:\software\winedt10\Miktex\tex/latex/graphics\trig.sty)
(D:\software\winedt10\Miktex\tex/latex/graphics-cfg\graphics.cfg)
(D:\software\winedt10\Miktex\tex/latex/graphics-def\dvips.def)))
(D:\software\winedt10\Miktex\tex/latex/latex-tools\multicol.sty)
(D:\software\winedt10\Miktex\tex/latex/graphics\color.sty
(D:\software\winedt10\Miktex\tex/latex/graphics-cfg\color.cfg)
(D:\software\winedt10\Miktex\tex/latex/graphics\dvipsnam.def))
(D:\software\winedt10\Miktex\tex/latex/txfonts\txfonts.sty))
(D:\software\winedt10\Miktex\tex/latex/txfonts\ot1txr.fd)
(D:\software\winedt10\Miktex\tex/latex/l3backend\l3backend-pdftex.def)
No file Journal_Tex_template_manual.aux.
(D:\software\winedt10\Miktex\tex/latex/txfonts\omltxmi.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\omstxsy.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\omxtxex.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\utxexa.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\utxmia.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\utxsya.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\utxsyb.fd)
(D:\software\winedt10\Miktex\tex/latex/txfonts\utxsyc.fd)
(D:\software\winedt10\Miktex\tex/latex/psnfss\ot1phv.fd)

It always stuck at (D:\software\winedt10\Miktex\tex/latex/psnfss\ot1phv.fd), and I do have this file in the right place. So, I don't understand why the compiling cannot go on.

Maybe someone can give me some useful suggestions. THX
Attachments
fig.jpg
fig.jpg (14.77 KiB) Viewed 920 times
table.jpg
table.jpg (185.61 KiB) Viewed 920 times
jsme-tj.cls
(72.94 KiB) Downloaded 17 times
Journal_Tex_template_manual.tex
(12.9 KiB) Downloaded 13 times

rais
Posts: 296
Joined: Sun Nov 16, 2014 8:51 pm

Postby rais » Sun Oct 03, 2021 3:57 pm

Your class file contains the line
\DeclareRobustCommand{\,}{\thinspace}%

which creates an infinite loop with a fairly recent LaTeX-Kernel, as soon as you try to call \, (and \, is called within \maketitle here). Delete that line and notify the maintainer of that class.

KR
Rainer

ouros
Posts: 2
Joined: Sat Oct 02, 2021 10:44 am

Postby ouros » Thu Oct 07, 2021 9:58 am

rais wrote:Your class file contains the line
\DeclareRobustCommand{\,}{\thinspace}%

which creates an infinite loop with a fairly recent LaTeX-Kernel, as soon as you try to call \, (and \, is called within \maketitle here). Delete that line and notify the maintainer of that class.

KR
Rainer


Hi,

It really works, thank you. But another problem has arisen, the picture in it is only black, even the abstract section.

I think it may be related to these logs:
[2
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color push rgb .7412 .7647 .8863
Non-PDF special ignored!
<special> color push rgb .7412 .7647 .8863
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push rgb 0 0 0
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color push rgb .0235 .3608 .6588
Non-PDF special ignored!
<special> color push rgb .0235 .3608 .6588
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color push Black
Non-PDF special ignored!
<special> color push gray 1
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
Non-PDF special ignored!
<special> color pop
]

May you have some clues on it. Thank you again!

Binzi Xu

User avatar
Ijon Tichy
Posts: 565
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Thu Oct 07, 2021 10:16 am

The class is relates on: TeX-source → LaTeX → DVI-file → dvips → PS -file→ pstopdf → PDF-file, instead of: TeX-source → pdfLaTeX → PDF-file. You can try to delete all the dvips options in the class file. However, if the publisher wants this (in our days outdated) build process, you should use it. Moreover, if the class has an mistake like the \, you should contact the publisher. Maybe there is already a newer version of the class somewhere available from the publisher.

BTW: In the class even a \usepackage command has been used. But classes should not use \usepackage but \RequirePackage only. So if you edit the class, you should change this too.

Please note: The community is not responsible for non-free classes or packages. Nor can we change the class. If there are problems with such classes or packages, you should always contact the maintainer of the class/package or in your case your publisher contact.

Note also: If you change the class or the build process, you should additionally inform the publisher of your change. Otherwise is could happen, that the original build process of the publisher will fails.


Return to “WinEdt”

Who is online

Users browsing this forum: No registered users and 2 guests