LaTeX forum ⇒ Texmaker and TeXstudioSet UTF8 as default encoding

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
Cherrys
Posts: 4
Joined: Thu Sep 05, 2013 5:48 pm

Set UTF8 as default encoding

Postby Cherrys » Thu Sep 10, 2015 8:42 pm

Hi

Whenever I try to open a latex document that's written in UTF8 encoding (which I need for accents and stuff), I get an error message saying that it can't be decoded with the default encoding (windows-1252), and suggests to open it with UTF8. If I do that, everything works fine. But I still get the same message every single time I open a .tex document.

I tried to change the encoding in option-configure texmaker editor, but it goes back to windows-1252 whenever I try to open a new document, and gives me the same message. Even if I have an open document, change the setting, and while the document is still open, open another document (in another tab). The setting automatically gets back to windows-1252.

And the same thing happens on different computer, one with windows 7, the other with windows 8...

So, is there any way to fix this? It's nothing terrible, but just a little annoying to always have to close the same error message every time... :)

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 3795
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Sep 11, 2015 4:21 pm

That sounds strange. Set the option as in this linked picture (sorry, it is in german) and close texmaker.
Does it work with the next restart?

Is it an up to date version?
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 3 guests