LaTeX forum ⇒ Texmaker and TeXstudioSyncTeX Compiler Option not recognized

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
nomdemprunt
Posts: 5
Joined: Wed Feb 06, 2013 1:44 pm

SyncTeX Compiler Option not recognized

Postby nomdemprunt » Wed Feb 06, 2013 1:51 pm

Hello,

I try to use TeXmaker. I make the configuration with the advice of this website. So i configure this.
  1. pdflatex -synctex=1 -interaction=nonstopmode %.tex

But the answer of the compiler is always "'-synctex=1' unrecognized option" without any other information. An idea?

Thanks

Tags:

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Thu Feb 07, 2013 2:07 pm

What does pdflatex --version report?
Joseph Wright

nomdemprunt
Posts: 5
Joined: Wed Feb 06, 2013 1:44 pm

Postby nomdemprunt » Thu Feb 07, 2013 2:48 pm

You mean the answer is somewhere on this webpage ?
Sorry but i don t find

User avatar
Johannes_B
Site Moderator
Posts: 4044
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Thu Feb 07, 2013 2:52 pm

You can open a terminal or the command line (Windows start -> run -> cmd.exe) and type
  1. pdflatex --version
press enter and tell us the results.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

nomdemprunt
Posts: 5
Joined: Wed Feb 06, 2013 1:44 pm

Postby nomdemprunt » Thu Feb 07, 2013 3:15 pm

pdfTeX using libpoppler 3.141592-1.40.3-2.2 (Web2C 7.5.6)
kpathsea version 3.5.6



on linux

User avatar
Stefan Kottwitz
Site Admin
Posts: 9444
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Thu Feb 07, 2013 3:25 pm

As Joseph and Johannes guessed, your pdfTeX version is too old and doesn't support synctex yet. You need to update your TeX installation. synctex support has been added in pdfTeX 3.1415926-1.40.8 (released on 2008-07-10), the newest is pdfTeX 3.1415926-1.40.10. 3.1415926 means the TeX version, 1.40.10 the pdfTeX release.

Stefan
Site admin

nomdemprunt
Posts: 5
Joined: Wed Feb 06, 2013 1:44 pm

Postby nomdemprunt » Thu Feb 07, 2013 3:48 pm

Vielen Dank.

nomdemprunt
Posts: 5
Joined: Wed Feb 06, 2013 1:44 pm

Postby nomdemprunt » Mon Feb 25, 2013 5:18 pm

Hum
I update texmaker but it seems it was not the thing to do to update pdftex.
When i search on internet i just found : you have to update texmaker.
I try but the answer:

Can't install /var/tmp/texmaker_fedora17-3.5.2-xm1.x86_64.rpm as no transaction

Any solution ?
Thanks

MRC
Posts: 2
Joined: Wed Feb 26, 2014 1:36 pm

Postby MRC » Wed Feb 26, 2014 1:45 pm

Hello,

I'm new in LaTeX, but I've noticed my SyncTeX compiler doesn't work either.

In my case, I'm using TeXmaker 4.1.1 (the latest version I know of) and it doesn't work. I also specified the SyncTeX code

pdflatex -synctex=1 -interaction=nonstopmode %.tex/

but still doesn't work.

Have you got any idea of what I can do?

Thank you in advance

hugovdberg
Posts: 133
Joined: Sat Feb 25, 2012 6:12 pm

Postby hugovdberg » Thu Feb 27, 2014 9:51 pm

Johannes_B wrote:You can open a terminal or the command line (Windows start -> run -> cmd.exe) and type
  1. pdflatex --version
press enter and tell us the results.

The Texmaker version is not the same as the latex version. Please tell us which pdflatex version you use.
Ubuntu 13.10 + Tex Live 2013 + Texmaker / Windows 7 Pro + MikTex 2.9 + TexnicCenter / Android 4.3 + TexPortal + DroidEdit


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 2 guests