LaTeX forum ⇒ Texmaker and TeXstudioQuickbuild File Not Found Topic is solved

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
Its_like_Lagrange
Posts: 3
Joined: Wed Oct 22, 2014 7:46 am

Quickbuild File Not Found

Postby Its_like_Lagrange » Wed Oct 22, 2014 8:03 am

Hi, I'm new to Texmaker and to Latex. I followed this tutorial https://www.youtube.com/watch?v=SoDv0qhyysQ and by the time I tried to see the PDF of my document I received the error: File Not Found.

As far as I've seen I can compile the file with PDFLatex (F6). And I won't receive any error. Yet the pdf file is not created and does not appear in my working directory.

When I use QuickBuild directly is when I get the error.

I tried using the built in pdf viewer as well as the external viewer from Adobe.

I already checked several forums with similar issues, yet all answers lead back to "use F6 the first time to compile the file." But that has not worked.

I thank you in advance for your help.

Some extra details:
I'm running Texmaker on Windows 7. I'm using the MixTek 2.9 Latex distribution.

User avatar
Johannes_B
Site Moderator
Posts: 4185
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Oct 22, 2014 9:11 am

Please don't use spaces in file names like the narrator in the video. That is very bad practice.
Make sure to save the file with the ending .tex (should be the default).

I always recommend to start with a basic editor like Texworks (mentioned in the video and installed with MikTeX). You learn the basic interaction with the underlying program. Switching to a fancy editor with trillions of magical functions can be done a few hours later.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Its_like_Lagrange
Posts: 3
Joined: Wed Oct 22, 2014 7:46 am

Postby Its_like_Lagrange » Wed Oct 22, 2014 7:30 pm

Johannes_B wrote:Please don't use spaces in file names like the narrator in the video. That is very bad practice.
Make sure to save the file with the ending .tex (should be the default).

I always recommend to start with a basic editor like Texworks (mentioned in the video and installed with MikTeX). You learn the basic interaction with the underlying program. Switching to a fancy editor with trillions of magical functions can be done a few hours later.


Thank you very much. Indeed I have not named any of my files using spaces.

And I'll check Texworks. Thank you :)

Its_like_Lagrange
Posts: 3
Joined: Wed Oct 22, 2014 7:46 am

Postby Its_like_Lagrange » Wed Oct 22, 2014 7:31 pm

A friend just helped me fix the issue.

I went to the Options menu -> Configure Texmaker -> Commands

And in the PdfLaTeX section I inserted this:
pdflatex -synctex=1 -interaction=nonstopmode %.tex

I do not know why it fixed it. But it did. :)

aban
Posts: 1
Joined: Sun Dec 06, 2020 7:14 pm

Postby aban » Sun Dec 06, 2020 7:18 pm

Its_like_Lagrange wrote:A friend just helped me fix the issue.

I went to the Options menu -> Configure Texmaker -> Commands

And in the PdfLaTeX section I inserted this:
pdflatex -synctex=1 -interaction=nonstopmode %.tex

I do not know why it fixed it. But it did. :)

I had the same issue, I did what you mentioned, it's fixed now, thank you very much. :)


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 2 guests