LaTeX forum ⇒ Texmaker and TeXstudioTexStudio can't generate pdf

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
PinkyPao
Posts: 3
Joined: Tue May 08, 2018 3:14 am

TexStudio can't generate pdf

Postby PinkyPao » Tue May 08, 2018 4:35 am

Hello, please help me!

I've been working on my dissertation for two years and I haven't had any problem while compiling it until yesterday. I use a Mac. I was working and when I compile it pops this message: - does not look like a valid PDF document. Either the file is corrupt or it is in the process of creation. Retrying every two seconds.

I need to compile it two or three times before it works and it takes a long time. I've tried my code on a windows computer and it doesn't have any problem. I've tried fixing it by changing the path in the commands of texStudio, but it makes anything. What hat happened? Can I fix it somehow?

Thank you in advance. I am really desperate because I really need to work and it takes two or three compilations before it generates the file.

tesis.log
This is the log file my code generates only while working on a mac
(42.29 KiB) Downloaded 23 times
Last edited by PinkyPao on Wed May 09, 2018 2:24 am, edited 1 time in total.

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 3825
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Tue May 08, 2018 7:34 am

You seem to panic. DON'T PANIC!

Get a cup of coffee and relax.

Something you did to your document, or something to your installation (maybe an admin did something) seems to have changed something.

Maybe everything is just fine? Maybe. LaTeX documents need to be compiled several times, and this also takes time. I don't know.

See how vague I am? I cannot be any more specific based on the information you are providing.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9019
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Tue May 08, 2018 10:35 am

Welcome to the forum!

If the compilation fails, the .log file shows the errors. Can you please post the .log file here, as attachment? The attachment link is below the text edit field, when writing a post in the forum.

Stefan
Site admin

PinkyPao
Posts: 3
Joined: Tue May 08, 2018 3:14 am

Postby PinkyPao » Wed May 09, 2018 2:27 am

Thankyou very much! You're really kind. I have updated the post so there is my log file. ;)


Stefan Kottwitz wrote:Welcome to the forum!

If the compilation fails, the .log file shows the errors. Can you please post the .log file here, as attachment? The attachment link is below the text edit field, when writing a post in the forum.

Stefan

PinkyPao
Posts: 3
Joined: Tue May 08, 2018 3:14 am

Postby PinkyPao » Wed May 09, 2018 2:41 am

I'm really in a panic. I need to end my dissertation tomorrow and I can't work at home because the file doesn't creates the pdf.

I'm sorry I haven't been clear enough, now I have loaded the log file, so maybe the problem is clearer. Actually, I don't know what has happened, therefore I can not give more info, as I said before, my code used to work and compile every day for the last two years and now it works only after three compilations. The only change I have made in my laptop is a security update from the software (iOS High Sierra version 10.13.4) 3 days ago, but my code worked okay after it for a day.

I don't mean to annoy you, but as you can see I'm deeply desperate.

Johannes_B wrote:You seem to panic. DON'T PANIC!

Get a cup of coffee and relax.

Something you did to your document, or something to your installation (maybe an admin did something) seems to have changed something.

Maybe everything is just fine? Maybe. LaTeX documents need to be compiled several times, and this also takes time. I don't know.

See how vague I am? I cannot be any more specific based on the information you are providing.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9019
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed May 09, 2018 9:56 am

The .log file is incomplete. After a warning (duplicate hyperlink identifier) that's not important (just ignored) the file ends with

l.4 \end{dedication}
[1


so right at the beginning (page 1, dedication), no other messages, no errors.

Without additional information, we cannot guess what goes wrong with your files.

I understand that you may not want to share the full document here and that you may not have the time to gather and post the information to find the error. If you are in a hurry, you could zip/compress your document folder (with all document data) and send it to me at stefan@latex.org. I could have a look. The technical discussion will continue here once I saw the technical reason (if I find it). If you have a better idea, let us know. (Other idea: if you think your laptop installation has an issue, run TeX on another computer or use Overleaf online - the latter one is difficult with a complex document. Or I compile for you if you send the code to my personal email and send the PDF back as email)

I'm just traveling so not looking every hour into email.

Stefan
Site admin


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 1 guest