LaTeX forum ⇒ KilePDF viewer always opens at the first page

Information and discussion about Kile, an integrated LaTeX environment for Linux KDE
Gilles T
Posts: 2
Joined: Sat Jan 09, 2021 1:42 pm

PDF viewer always opens at the first page

Postby Gilles T » Sat Jan 09, 2021 1:49 pm

Hi,

This is my first topic.

I'm working on a book, compiling with Xelatex (Kile 2.9.93, Ubuntu 20.10). When I turn around to see my latest changes on PDF (ViewPDF or ForwardPDF), it opens every time in the beginning. I wish to go directly to my latest changes.

I hope to find some help,

Thanks

User avatar
Ijon Tichy
Posts: 392
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Sat Jan 09, 2021 2:04 pm

If your viewers are synctex compatible you could try to compile using option -synctex. See man synctex for more information about synctex and man xetex or texdoc xetex or xelatex --help for more information about the command line options of xetex and so xelatex.

For more information about synctex with, e.g., kile + okular → Synctex in Kile and Okular. For projects with multiple files see also Multi-document project in Kile+Okular.

Another suggestion would be to try an editor with internal PDF viewer like TeXstudio, TeXmaker, TeXworks.

Disclaimer: I'm neither using Kile nor Ubuntu nor TeX nor TeXstudio nor TeXmaker nor TeXworks.

Gilles T
Posts: 2
Joined: Sat Jan 09, 2021 1:42 pm

Postby Gilles T » Sat Jan 09, 2021 3:59 pm

Thanks Ijon Tichy for your quick answer.

My viewers are apparently synctex compatible and by default set to be.

In the present version of Kile, the ViewPDF and ForwardPDF are internal PDF viewers. I tried to use the tips given in the link Synctex in Kile and Okular, by I did not succeed to sold my problem.


Return to “Kile”

Who is online

Users browsing this forum: No registered users and 4 guests