LaTeX forum ⇒ KileKile - problem with accents characters in the kile editor

Information and discussion about Kile, an integrated LaTeX environment for Linux KDE
eliso
Posts: 1
Joined: Fri Jun 07, 2019 10:28 am

Kile - problem with accents characters in the kile editor

Postby eliso » Fri Jun 07, 2019 10:42 am

Hi all,
it's my first question on this forum.
So don't hesitate to tell me if i am doing something wrong ;)

I use Kile since several years now and never had this trouble : I am writing a document in french
and all the accents are displayed well in the .pdf output, when I compile with PdfLatex.
However, in the Kile editor my accents are sometimes swapped by weird Chinese characters.

So i erase them and put an 'é' for instance and then when i compile i've got "?" instead of my "é" in the .pdf file.

When I open the .tex file with another code editor (like gedit) i am able to see the "é" characters without trouble.
I am running Kile on Ubuntu 18.04 .

Do you have any idea what would be the origin of this trouble ?

Thanks by advance,
Regards,


Elie

User avatar
Ijon Tichy
Posts: 91
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Fri Jun 07, 2019 11:18 am

It seems that the encoding setting of kile differs from the encoding of the file. This can happen if the encoding detection fails and the fallback encoding is incorrect. See chapter 13 of the kile manual how to change the encoding detection and the fallback encoding. Make also sure, that the option of package inputenc corresponds with the real encoding of the file.

BTW: In opposite to chapter 13 of the kile manual you should not use package ucs or package xltxtra. Also note, the default encoding of up-to-date LaTeX enginges is UTF8. So files that produce the correct output without loading inputenc are UTF8 encoded if you are using an up-to-date LaTeX.


Return to “Kile”

Who is online

Users browsing this forum: No registered users and 1 guest