LaTeX forum ⇒ LyXThe module requires a package that is not available in your LaTeX installation

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Gnosos
Posts: 20
Joined: Wed Jun 29, 2011 10:52 pm

The module requires a package that is not available in your LaTeX installation

Postby Gnosos » Fri Jul 31, 2020 7:07 pm

I've never installed a module in LyX before and am having a heck of a time getting the sage module to work. I've followed this page's instructions for installing sagetex on a multiuser system and specifically for LyX here. But because I'm using MacOS 10.14, I installed the sage.module in ~/Library/Application Support/LyX-2.3/layouts.

Despite everything, when I open the example.lyx that comes with the module, I get this error message: "The module sage requires a package that is not available in your LaTeX installation, or a converter that is not installed. LaTeX output may not be possible. Missing prerequisites: sagetex.sty. ..."

But if in LyX I choose: Tools > TeX Information .. LaTeX styles and scroll way down, sure enough sagetex.sty is in the list.

What could possibly be wrong? :cry:

Return to “LyX”

Who is online

Users browsing this forum: No registered users and 4 guests