LaTeX forum ⇒ LyXInstalling fancyhdr.sty in Lyx 2.3

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
christo_91
Posts: 4
Joined: Wed May 29, 2019 11:27 am

Installing fancyhdr.sty in Lyx 2.3

Postby christo_91 » Fri Sep 13, 2019 7:33 pm

Hi,

I'm trying to install the fancyhdr.sty package to Lyx so that I can add and amend headers but I'm struggling to get the program to recognise the packages (there are three; extramarks, fancyhdr and fancyheadings). I've currently tried putting the 3 files into the 'Resources' --> 'tex' subfolder of Lyx but that doesn't seem to have worked?

Any help please?

Thanks,


Christo.

User avatar
Ijon Tichy
Posts: 120
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Sat Sep 14, 2019 12:06 pm

LyX is a frontend to LaTeX. You should install packages with the package manager of the TeX distributions, e.g., the tlmgr of TeX-Live or the MiKTeX console of MiKTeX.

BTW: fancyheadings is a deprecated LaTeX 2.09 package. You should not use it. Use either it's official successor fancyhdr or another up-to-date pagestyle package. IMHO LyX itself uses fancyhdr, if you use the LyX settings to setup the page head and foot. Package extramarks is part of the fancyhdr bundle and will be installed with that package, if you use the package manager of the TeX distribution to install fancyhdr.

yasha_8226
Posts: 2
Joined: Sat Sep 14, 2019 4:50 pm

Postby yasha_8226 » Sat Sep 14, 2019 5:19 pm

hi . im yasha . i have question . when i copy text from word and copy to latext warning :




proeng-template.tex

LaTeX Warning: Unused global option(s): [procedia].

christo_91
Posts: 4
Joined: Wed May 29, 2019 11:27 am

Postby christo_91 » Sun Sep 15, 2019 12:19 pm

Ijon Tichy wrote:LyX is a frontend to LaTeX. You should install packages with the package manager of the TeX distributions, e.g., the tlmgr of TeX-Live or the MiKTeX console of MiKTeX.

BTW: fancyheadings is a deprecated LaTeX 2.09 package. You should not use it. Use either it's official successor fancyhdr or another up-to-date pagestyle package. IMHO LyX itself uses fancyhdr, if you use the LyX settings to setup the page head and foot. Package extramarks is part of the fancyhdr bundle and will be installed with that package, if you use the package manager of the TeX distribution to install fancyhdr.


Thanks for this. I've checked in MikTex and it says the package is installed, but when I go into Lyx ('Document settings' --> 'Modules') and select 'Custom Headers and Footers' it says "Packages required: fancyhdr.sty" and "Filename: customHeadersFooters.module" ... I'm guessing this means that Lyx hasn't got the package installed within itself? Do you know what I'm doing wrong?

Thanks,

rais
Posts: 235
Joined: Sun Nov 16, 2014 8:51 pm

Postby rais » Sun Sep 15, 2019 10:12 pm

christo_91 wrote:I've checked in MikTex and it says the package is installed, but when I go into Lyx ('Document settings' --> 'Modules') and select 'Custom Headers and Footers' it says "Packages required: fancyhdr.sty" and "Filename: customHeadersFooters.module" ...

If memory serves, you need to tell LyX to scan for installed LaTeX packages, after you installed one (or more).

KR
Rainer


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 5 guests