LaTeX forum ⇒ LyXLyX compilation takes forever?

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Posts: 42
Joined: Mon May 10, 2010 5:17 pm

LyX compilation takes forever?

Postby lyxer » Wed Feb 21, 2018 2:41 pm


I have a problem when compiling a document in Lyx. First of all, this problem occurs only with
beamer documents, documents of type article compile fine. Whenever I compile
the beamer file I get "The command pdflatex 'document name' has not yet completed. Do you want
to stop it?". If I click "Let it run" I get the same message again, and if I click "stop it" it doesn't stop.
So, I have to force quit Lyx. The problem is that previously (a few months ago) everything worked fine.

I'm using Acrobat Reader DC with Lyx 2.2.3 on Windows 10. I tried switching to SumatraPDF but the problem
still persists especially with large beamer documents.

What seems to be the problem? Any suggestion on how to fix it? Is there anything I can do with the settings?

Last edited by lyxer on Thu Feb 22, 2018 10:40 pm, edited 1 time in total.

User avatar
Site Moderator
Posts: 4011
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Feb 21, 2018 3:15 pm

Export to LaTeX and compile from the command line, 8 guess you are missing packages.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Posts: 42
Joined: Mon May 10, 2010 5:17 pm

Postby lyxer » Wed Feb 21, 2018 5:39 pm

I exported it to Latex and opened it in winedt. While compiling it stopped and gave the
following messages, which I'm not sure what they mean exactly. I'm attaching the error message
which refers to lines 352 and 372. I'm also attaching part of the code that includes these two lines.
code.png (195.24 KiB) Viewed 2018 times
err_msg.png (61.33 KiB) Viewed 2018 times

Posts: 42
Joined: Mon May 10, 2010 5:17 pm

Postby lyxer » Thu Feb 22, 2018 10:40 pm


I think it's working now. I commented the lines in winedt and the file compiled just fine.
So, I removed the whole frame corresponding to these lines from Lyx and it compiled fine.
I guess there was an error because of the overprints and list I used previously. Although I don't
know what the error was, I'm happy it's working now. I'll check the other beamer files.

Thanks for the hint of Exporting to Latex Johannes_B.

Return to “LyX”

Who is online

Users browsing this forum: No registered users and 2 guests