LaTeX forum ⇒ LyXExport to odt/docx skips words in a different language Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
RHvdG
Posts: 5
Joined: Sat Apr 15, 2017 5:31 pm

Export to odt/docx skips words in a different language

Postby RHvdG » Tue Dec 26, 2017 2:41 am

I'm puzzled by the following reproducible occurrence: when exporting from LyX (Mac, 2.2.3) in the resulting .docx and .odt documents words tagged as 'German' are skipped. They simply don't show. A full block quote in German is displayed without any trouble, but inline German words are all missing (also when they're not in quotes). I'm attaching screen shots of the PDF output (no problems there), the .docx output (problems) and the same phrase in the LyX environment. Any help is appreciated.
Attachments
pdf.png
pdf.png (14.67 KiB) Viewed 1081 times
lyx.png
lyx.png (17.14 KiB) Viewed 1081 times
doc.png
doc.png (11.5 KiB) Viewed 1081 times

Tags:

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Tue Dec 26, 2017 7:07 am

Note that an external converter is used to convert to .odt/.doc, so you might want to report the issue to the external program. See Preferences > Converters to know which external tool is being used.

RHvdG
Posts: 5
Joined: Sat Apr 15, 2017 5:31 pm

Postby RHvdG » Tue Dec 26, 2017 6:04 pm

Thanks. It's pandoc. I filled a bug report here https://github.com/jgm/pandoc/issues/4199, and the bug has been acknowledged.


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 4 guests