LaTeX forum ⇒ LyXLyx 2.2.3 → bigfoot errors

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
ExecutorElassus
Posts: 90
Joined: Wed Sep 07, 2011 3:14 pm

Lyx 2.2.3 → bigfoot errors

Postby ExecutorElassus » Wed May 24, 2017 5:51 pm

Yesterday I updated Lyx to 2.2.3, and now I'm getting a bunch of errors in PDF export. I'm using XeLaTeX, among other things.

On my MWE files, I get an error about biblatex having a mismatched control file ("found version 3.3, was expecting 3.1"). For that, I suppose I'll just have to wait for my distribution to release the new version of biblatex to match.

On my large main document, though, I am getting a weird error about bigfoot. The error reads:

  1. ! Package bigfoot Error: \footinsdefault forbidden in \footinsdefault ..


(on the side, is there any way to get these error messages to be any longer? Having the error message cut off like that makes it hard to get any sensible information about the problem).

I don't find anything on the Internet about this particular error, but -- as Lyx is the only part of the toolchain I've updated recently -- I assume it lies somewhere in how the new version is formatting footnotes.

Is there any further information I can provide to help track down the issue?

Thanks in advance for the help.

Cheers,

EE

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 8734
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Wed May 24, 2017 7:01 pm

You may see a longer error text in the .log file. I saw that error message 10 years ago, so I think it is not a broken update but just a problem with the code. Perhaps it's undesired nesting of footnotes, such as footnote citations in a footnote.

Stefan
Site admin


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 3 guests