LaTeX forum ⇒ LyXIncorrect display of English that's inline with Hebrew text

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
danielbog
Posts: 6
Joined: Mon Mar 20, 2017 3:00 pm

Incorrect display of English that's inline with Hebrew text

Postby danielbog » Mon Mar 20, 2017 3:35 pm

Hello everyone,

I'm new to LyX and LaTeX (coming from LibreOffice, Word, etc.) and I really like what LyX offers in terms of text formatting.

I'm writing a Hebrew article and I have trouble writing English inline with Hebrew.
The problem is that when I write English text on it's own new line, it's all fine, but when an English word appears between Hebrew text, the PDF that is produced is a little strange: the embedded English is all CAPITAL, and an annoying 'L' letter is appended to it. A screenshot is added for demonstration.

How can I fix this issue?

I'm running a 64-bit Ubuntu 16.04 and Lyx v2.2.2
To add Hebrew support I have installed the required packages and changed the encoding to cp1255.
I have assigned a shortcut (F10) to switch to English (primary keyboard null, secondary is Hebrew).

Appreciate any advice.
Attachments
lyx1.png
lyx1.png (44.88 KiB) Viewed 1791 times

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Tue Mar 21, 2017 7:00 am

Can you please post the .lyx file associated with the screenshot? Ideally you could post this as a bug on https://www.lyx.org/trac , but if you post a .lyx file I'll take a look at it.

danielbog
Posts: 6
Joined: Mon Mar 20, 2017 3:00 pm

Postby danielbog » Sat Mar 25, 2017 12:12 pm

Yep, here it is.

I don't know if it's a bug... But if you can spot something suspicious I'll post it.
Thank you !
Attachments
en-he-test.lyx
(4.03 KiB) Downloaded 45 times

danielbog
Posts: 6
Joined: Mon Mar 20, 2017 3:00 pm

Postby danielbog » Tue Mar 28, 2017 4:18 pm

Unfortunately I've just spotted the same problem with Math Mode.
Switching to Math Mode with 'Ctrl+M' will result in capitalized math text with the 'L' letter appended to the end of it.

Have searched extensively for a solution to no avail.
How can I fix this problem?

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Wed Mar 29, 2017 1:36 am

I tried your document but it doesn't compile to PDF for me. Is the preamble necessary? Do you compile with XeTeX or pdfTeX?

If I go to Document > Settings > Fonts and click on the checkbox "Use non-TeX fonts" and then set them to FreeSans, and then compile with XeTeX, I get a PDF that seems correct to me. Does that work for you?

I'm on Ubuntu with TeX Live 2016 and LyX 2.2.2. I attach the files for convenience.
Attachments
en-he-test.pdf
(7.42 KiB) Downloaded 34 times
en-he-test.lyx
(3.99 KiB) Downloaded 34 times

danielbog
Posts: 6
Joined: Mon Mar 20, 2017 3:00 pm

Postby danielbog » Thu Mar 30, 2017 8:46 pm

Thank you for your reply scottkosty,

What preamble do you mean ? :?

Unfortunately changing the font settings as you said, produces the following errors (only the relevant first few lines):
  1. Right-to-Left Support Error: use TeX--XeT or e-TeX engine.
  2. Package inputenc Error: inputenc is not designed for xetex or luatex.


A quick check suggested that it may be a problem with XeTeX/TeX Live, so I've reinstalled it but the same error persists.
Do you compile with XeTeX or pdfTeX?

I'm not sure which one, but the format I choose before viewing the pdf (Ctrl+R by default) is pdfLatex (actually, an option for XeTeX isn't listed there at all).

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Fri Mar 31, 2017 7:29 am

Dang. What if you try downloading the .lyx file instead of following the steps. Do you still get the same error if you try to compile it without changing anything?

danielbog
Posts: 6
Joined: Mon Mar 20, 2017 3:00 pm

Postby danielbog » Fri Mar 31, 2017 10:38 am

Yep of course I have also tried it before posting the reply :) .

I guess it's worth trying to reinstall lyx with all its dependencies and retry.
I'll report back once I try that on a freshly installed lyx (unless someone has another idea ?)

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Fri Mar 31, 2017 6:35 pm

danielbog wrote:Yep of course I have also tried it before posting the reply :) .

I guess it's worth trying to reinstall lyx with all its dependencies and retry.
I'll report back once I try that on a freshly installed lyx (unless someone has another idea ?)


I think it is rather your LaTeX installation. Are you using TeX Live from the Ubuntu repository or did you install it manually? If you used it from the Ubuntu repository, it is probably not up to date.

The following will take time, but I think it is the safest to proceed:
Install Ubuntu 16.04 in a virtual box (this is very easy).
Run

  1. sudo ./install-tl-ubuntu --hebrew


which you can clone from here:
https://github.com/scottkosty/install-tl-ubuntu

Then see if the .lyx file that I posted here works on that. If so, then it means the difference was our LaTeX installations.

scottkosty
Site Moderator
Posts: 528
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Fri Mar 31, 2017 6:35 pm

I forgot to say, install LyX *after* that command not before (cause if you do it before then it will install TeX Live from the Ubuntu repos).


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 2 guests