LaTeX forum ⇒ LyXLyX and Papers2 citekey problem

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Posts: 16
Joined: Thu Mar 14, 2013 4:58 pm

LyX and Papers2 citekey problem

Postby TMorville » Sat Oct 25, 2014 1:07 pm


Recently I've been having trouble with the 'Insert Citekey' function from Papers2. For those of you who don't know Papers2, it's a neat way to keep your papers organized and easily accessible for citing. Except when it isn't working.

When i tab the "Insert citekey" or "Insert formatted citekey" nothing happens. It says "Inserting citekey", then "Finished" and disappears, but nothing appears in Lyx. I even tried upgrading Lyx to 2.1.2 from the 2.1.0beta2 which was the first version working with a retina screen on a MBP, but no avail. I have a full bibtex file attached to my Lyx, and inserting citations works fine when i do it through LyX.

Have anyone had similar experiences with Papers2?

PS. My version of Papers2 works fine in other texteditors, such as Word.

Posts: 16
Joined: Thu Mar 14, 2013 4:58 pm

Postby TMorville » Thu Nov 13, 2014 2:00 pm

So. I solved the above problem by installing Papers3.

Now I have a new issue.

If i use Papers3 to insert e.g. [#Keramati:2014cq] then Lyx outputs it as text, and does not format it as a source. When i manually add the source, via. "Insert citation" - it works fine, as has a grey box around it, which points to the corrent paper.

Any solutions to this?

Return to “LyX”

Who is online

Users browsing this forum: No registered users and 4 guests