LaTeX forum ⇒ LyXpdf latex not availeble in lyx Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Posts: 3
Joined: Tue Jul 22, 2014 2:10 am

pdf latex not availeble in lyx

Postby hilbert » Tue Jul 22, 2014 2:22 am

I just installed the lyx 2.1.1 bundle on a 64 bit windows 7 machine.
I cannot generate pdf's since the view button is is not active.
Pdf's cannot be generated since in tools->preferences->file handling-> file formats i cannot select a default output format, there are non available.

When i try to reconfigure lyx i get the following error:
The system reconfiguration has failed.
default textclass is used but lyx may not be able to work properly.
please reconfigure again if needed.

When i look at the message plane it gives the following trace back for the reconfiguration error:
  1. Traceback (most recent call last):
  2. 10:09:05.738: File "C:/Program Files (x86)/LyX 2.1/Resources/", line 1536, in <module>
  3. 10:09:05.753: LATEX = checkLatex(dtl_tools)
  4. 10:09:05.753: File "C:/Program Files (x86)/LyX 2.1/Resources/", line 480, in checkLatex
  5. 10:09:05.753: if cmdOutput(PLATEX + ' chklatex.ltx').find('pLaTeX2e') != -1:
  6. 10:09:05.753: File "C:/Program Files (x86)/LyX 2.1/Resources/", line 68, in cmdOutput
  7. 10:09:05.753: cmd = 'cmd /d /c pushd ' + shortPath(os.getcwdu()) + '&' + cmd
  8. 10:09:05.753: File "C:/Program Files (x86)/LyX 2.1/Resources/", line 84, in shortPath
  9. 10:09:05.753: from ctypes import windll, create_unicode_buffer
  10. 10:09:05.753: File "C:\Python27\lib\ctypes\", line 10, in <module>
  11. 10:09:05.753: from _ctypes import Union, Structure, Array
  12. 10:09:05.753: ImportError: DLL load failed: %1 is not a valid Win32 application.

From the last line it looks as if there is a clash between a 64 bit python and 32 bit parts of lyx, but i am a bit out of my depth here.
Does anybody have any idea's what the root cause might be, and how i might go about fixing it?

Posts: 3
Joined: Tue Jul 22, 2014 2:10 am

Postby hilbert » Tue Jul 22, 2014 4:05 am

I solved the issue myself. Here is the answer for those who have the same problem.
Lyx is looking for python in the lyx directory: $LyXDir\Python;$LyXDir\Python\Lib; (Tools->preferences->Paths)
When i manually changed these to C:\Python27 and C:\Python27\Lib it did work.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9569
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Jul 23, 2014 10:10 pm

Hi hilbert,

welcome to the forum!

Thank you very much for adding the solution which you found yourself. This may help further people who arrive here via google looking for help with such a problem.

Stefan admin

Return to “LyX”

Who is online

Users browsing this forum: No registered users and 3 guests