LaTeX forum ⇒ LyXBibtex and quotation marks

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
butch
Posts: 2
Joined: Fri Jan 24, 2014 12:16 pm

Bibtex and quotation marks

Postby butch » Fri Jan 24, 2014 12:28 pm

Hi to all

I'm new to this forum because I have a problem using Lyx and Bibtex.
Writing my PhD in german I use the following quotation marks in my text: « ». If I export the file to pdf I looks great, no problems.
The problems begin if I include a bibtex-file (created with Bibdesk). All quotation marks written in the bib-file look strange after exporting the file to pdf. They look this way: « or »
I tried different things, I googled, I read websites, I have no clue!
Does anybody out there has an idea what my problem is and how I can solve it?
Thank you.

Regards
Butch

Tags:

StarValkyrie
Posts: 89
Joined: Fri Jan 24, 2014 12:42 am

Postby StarValkyrie » Sun Jan 26, 2014 7:35 pm

Did you type the guillemets directly? Sometimes BibTeX can't handle special characters when typed directly. You might need to try typing the tex code for right and left guillemets instead or sometimes you can just use quotation marks and the language option will translate them.

User avatar
Johannes_B
Site Moderator
Posts: 4044
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Mon Jan 27, 2014 11:07 am

I guess your bib-file ist utf8 encoded. Bibtex cannot work with those files, and a change to the modern package biblatex in conjunction with the bibliography processor biber might be useful.

If you want to stay with bibtex, you need to mask those symbols, using for example
  1. \documentclass{article}
  2. \usepackage[T1]{fontenc}
  3. \begin{document}
  4. \guillemotleft Hallo\guillemotright
  5. \end{document}
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

butch
Posts: 2
Joined: Fri Jan 24, 2014 12:16 pm

Postby butch » Mon Jan 27, 2014 10:58 pm

Thanks for your answers.
I changed Bibdesk's preferences to Latin 1, so my bib-file is latin-1 encoded now. It worked, everything looks as it should now.

Butch


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 2 guests