LaTeX forum ⇒ LyXSpell checking doesn't work in LyX 2.0.5.1 on OS X 10.6.8

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
GJacobs
Posts: 3
Joined: Tue Apr 09, 2013 12:40 pm

Spell checking doesn't work in LyX 2.0.5.1 on OS X 10.6.8

Postby GJacobs » Tue Apr 09, 2013 12:54 pm

Excuse me if this is a bit of an FAQ (I have searched already. A little reading suggests this has been a recurring problem for LyX but earlier notes indicate to my reading that developers thought they'd put it right in 2.0.3).

I've tried manually putting this right, but I'm out of time - I just can't keep plugging away at this bug forever as I have work to do, so hence asking here.

Bog standard install (.dmg), using smaller version of MacTex (TeXLive-2012-Basic).

Surely spelling check dictionaries for LyX get installed by default? Anyway, it seems there are none. None of the spelling options work (Native,* Aspell or Hunspell). Manually downloading and placing the dictionaries in /Library/Spelling does not help. Manually creating /usr/share/myspell/dict and manually places the dictionaries there does not help. LyX gives generic messages, e.g. "Spellchecker has no dictionaries" so I've no leads from that. (Where is it looking?, what is it looking for?, etc.)

(* It's not clear what "Native" *is*, either - the defaults in /Library/Dictionaries?)

Tags:

GJacobs
Posts: 3
Joined: Tue Apr 09, 2013 12:40 pm

Postby GJacobs » Wed Apr 10, 2013 1:12 am

For what little it's worth, I have found a work-around is to use the spell-checking in Skim (and open/free PDF viewer). It's a little clumsy as I have to manually take note of the error and revert to LyX to fix it but at least it's there.

This reveals an ugly quirk of LyX, however.

Many (all?) sequences of f+next letter are not being understood by Skim, so I presume LyX is generating these in some unexpected way. They visually look correct, but the effect is that clearly correct words with 'f' in them are flagged as errors, e.g. first, different.

scottkosty
Site Moderator
Posts: 531
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Wed Apr 10, 2013 1:19 am

Hi GJacobs,

If you can reproduce this bug on 2.0.5.1 (the newest version), please file a bug report
http://www.lyx.org/trac
so that it can be fixed for the next version.

I'm not sure how things work on Mac. I would not be surprised if the spell check dictionaries are not installed by default. Can you try installing one, reconfiguring LyX, and seeing if you still have a problem?

Scott

GJacobs
Posts: 3
Joined: Tue Apr 09, 2013 12:40 pm

Postby GJacobs » Fri Apr 19, 2013 10:22 am

I *think* have tracked the dictionary issue down.

I don't know enough of the internals to make full sense of this, but the issue appears to be a mix of an OS set up to prefer a variant of English and LyX "preferring" the default to be plain English. In this situation LyX seems to think (or reports) there are no dictionaries when in fact there are, it's just the English the system is using is a variant (e.g. English (UK)).

Here's what I've written elsewhere (lightly edited):

You can see this more clearly if you try use the Thesaurus. 'English' is offered but the pulldown list indicates it's not present, whereas
'English (UK)' is available to be used.

On systems that are not set with this as the default system version of English, the spellchecker "decides" it hasn't got a dictionary. The spellchecker then bails out without letting the user have the chance to try one of the other English variants. (Thesaurus by contrast lets you try them. The spellchecker complains about reaching the end of the document, then the spellchecker disappears.)

Manually setting the *system* (OS X) language to "prefer" English then the variants temporarily resolves this. But that's not suitable if you want (say) British English first.

A work-around seems to be to select the document language to be what you want (e.g. English (UK)) and select that setting to become LyX's default document language.

A "proper" solution, AFAICT, would be to have LyX realise that some
systems will not have "plain" English as a preferred language and correctly check what is in fact the system language in use. It's made more confusing, I think, by the LyX Preferences not having a setting for this - they only set the user interface language; the documents/spellchecking language seems to be separate, but that's not clear to users and the document language setting is a bit "buried", so many users won't be aware that there.

(Another, hopefully unrelated, confusion is that I have a system
Preference Pane for Spelling that something has installed (ha) that says it can't run on Intel-based systems...! Perhaps that "arrived" as a
consequence of installing Hunspell while I was trying to figure this
out.)



On an unrelated note, I'm still not sure what's up with the 'f' character issue, but it might be related to fonts.

scottkosty
Site Moderator
Posts: 531
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Fri Apr 19, 2013 12:51 pm

Glad you made some progress. Hopefully this gets figured out. I think that part of the problem is that there are only a couple of developers that sometimes use a Mac or Windows. Most use Linux. So sometimes system-dependent bugs like this are hard to work out.

GJacobs wrote:On an unrelated note, I'm still not sure what's up with the 'f' character issue, but it might be related to fonts.


This is because of ligatures. This is because of LaTeX, not LyX. There are probably changes that you can make. Perhaps searching for ligatures + LaTeX would lead to some tips.


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 3 guests