LaTeX forum ⇒ LyXInstalling a new document class

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
kleifest
Posts: 5
Joined: Tue Mar 20, 2012 9:28 pm

Installing a new document class

Postby kleifest » Thu Apr 04, 2013 11:29 pm

I've been trying for some time now to install a new document class in LyX to write a journal article, but have experienced much grief and no success thus far. Attached is the tBSH2e.cls file that I need. Along with the file were the following files:
amsfonts.sty, amsmath.sty, amssymb.sty, bbold11.fm, bbold11.tfm, doublesp.sty, floatflt.sty, mathbbol.sty, natbib.sty, rotating.sty

The files were downloaded from:
http://www.tandfonline.com/action/authorSubmission?journalCode=tbsh20&page=instructions

I have read every possible set of directions I could find on the internet to do this, and still haven't even been able to get the class to appear in LyX, not even as "unavailable."

I'm working on a laptop running Windows Vista (which is probably the root of all of my problems!).

I have tried to place the class the file (in an appropriately named tBSH2e folder along with any style files) in the following locations:
C:\Users\my_user_name\AppData\Roaming\MiKTeX\2.9\tex\latex
C:\Program Files\MiKTeX 2.9\tex\latex
C:\Program Data\MiKTeX\2.9\tex\latex

(I think these are the only places, but I can't remember as I have since deleted any files I had placed. I searched my computer for article.cls and tried placing my class file anywhere I found article.cls).

I also tried to create my own texmf tree in the Users folder, and added it to the file name database for MiKTeX, but that did nothing as well (although I may have done something incorrectly).

I also created an appropriate layout file and placed it in:
C:\Program Files\Lyx20\Resources\layouts (I'm not sure why there is a "Lyx20" folder in the first place)
C:\Program Files\Lyx2.0\Resources\layouts

I then ran texhash, as well as refreshed the FNDB and reconfigured LyX. Still, nothing.

I'm not sure what I'm doing wrong, and am very frustrated at this point. While I am quite familiar with LyX (I wrote my Masters Thesis in it), I have never installed a new document class. Any help with this issue would be greatly appreciated.
Attachments
tBSH2e.cls
(57.83 KiB) Downloaded 590 times

Tags:

User avatar
tom
Posts: 73
Joined: Thu Apr 18, 2013 4:02 am

Postby tom » Fri Apr 19, 2013 12:56 pm

Hi!

You have probably seen this guide: http://stefaanlippens.net/customLaTeXclassesinLyX.

Unfortunately, I'm not familiar with LyX layout files. However, I suggest you first figure out whether the problem is with the LyX file or the installation of the class file. Try running the following code with latex and if that works, your LyX file has a problem.

  1. \documentclass{tBSH2e}
  2. \usepackage{blindtext}
  3. \begin{document}
  4. \section{Dummy section}
  5. \blindtext
  6. \end{document}


Btw. I'm using texlive and copied the class to ../texlive/2012/texmf-dist/tex/latex/base/, where the standard classes are installed.


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 5 guests