LaTeX forum ⇒ LyXBlank Space(s) in Directory Path Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Posts: 11
Joined: Sat Jan 16, 2010 12:05 pm

Blank Space(s) in Directory Path

Postby davidpage » Sat Dec 03, 2011 3:13 pm

I have been using MikTeX 2.8 and has recently upgraded to MikTeX 2.9. To ensure my LyX (2.0) runs smoothly I uninstalled that and reinstalled the latest version (2.0.2), pointing it to my latest MikTex installation. However, when I use it to compile my document (Ctrl+R) a message box appears immediately saying that "The directory path to the document cannot contain spaces", an error that I have never encountered before. Yes I know my directory contains spaces but it worked fine before I did all these changes. Moving my file somewhere else works, but certainly it will be too troublesome to do that every time. Furthermore my directory is something like "D:\My Documents\blahblahblah" and I clearly cannot change "My Documents" to something else.

Is there an alternative method that can bypass this problem? Thanks!


Posts: 2
Joined: Fri Mar 16, 2012 2:33 am

Postby spuzzdawg » Mon Jul 30, 2012 12:28 pm


I see it been a fair while since you asked this question and no one has answered. I'm not sure if you still require an answer but I recently had the same problem so I'm sure others have come across this one as well. The problem is apparently a problem between Lyx and MikTex 2.9 when MikTex 'updates on the fly' is selected on. Deselect this option in MikTex settings and then reconfigure Lyx.

Hope this helps,

Posts: 2
Joined: Mon Dec 08, 2014 6:36 am

Postby pudding4869 » Mon Jul 13, 2015 10:29 am

Thanks spuzzdawg for posting.

I just want to say that the solution isn't working for me (on Windows 10 Preview 10162, Lyx 2.1.3, MixTex 2.9).

I'll get back if I find another solution.

Posts: 1
Joined: Wed Jan 27, 2016 1:45 pm

Postby phebyn » Wed Jan 27, 2016 1:46 pm

It worked for me... quite happy and thanks

Posts: 1
Joined: Tue Mar 21, 2017 5:51 pm

Postby androdri » Tue Mar 21, 2017 5:52 pm

It worked for me as well! Thanks!

Return to “LyX”

Who is online

Users browsing this forum: No registered users and 2 guests