LaTeX forum ⇒ LyXLyX 2.4 and exam.layout? Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Stef Pillaert
Posts: 51
Joined: Sat Oct 22, 2016 3:43 pm

LyX 2.4 and exam.layout?

Postby Stef Pillaert » Sun Jun 02, 2024 8:28 pm

I recently installed LyX 2.4 on windows 11. before that, I could use the exam.layout. But now I seem to have problems. I did copy the file exam.layout in the folder .../resources/layouts/, but when I open a LyX file that used to work with this layout in previous versions of LyX, I get "Layout file "exam" cannot be found".
Anyone an idea? I did try to reconfigure LyX, no succes...
Stef

Recommended reading 2021:

LaTeXguide.org • LaTeX-Cookbook.net • TikZ.org

Exclusive June 2024 offer: All LaTeX eBooks (PDF, EPBUB) for $9.99 or €8.99

LaTeX books

Stef Pillaert
Posts: 51
Joined: Sat Oct 22, 2016 3:43 pm

LyX 2.4 and exam.layout?  Topic is solved

Postby Stef Pillaert » Mon Jun 03, 2024 12:03 pm

I managed to get it to work again in LyX2.4, by manually pointig to the exam.layout file via document setting->Document classes -> Local document class (sorry, this is all translated from my Dutch GUI, probably not all correct).
Strange that LyX2.4 didn't seem to find the exam.layout automatically, since it was under C:\Program Files\LyX2.4\resources\layouts\exam/layout. Even after "reconfigure" of LyX.
scherm1.png
scherm1.png (71.97 KiB) Viewed 618 times

User avatar
Stefan Kottwitz
Site Admin
Posts: 10191
Joined: Mon Mar 10, 2008 9:44 pm

LyX 2.4 and exam.layout?

Postby Stefan Kottwitz » Mon Jun 03, 2024 12:05 pm

Hi Stef,

great that you solved it! Thanks for letting us know!

Stefan
LaTeX.org admin

Stef Pillaert
Posts: 51
Joined: Sat Oct 22, 2016 3:43 pm

LyX 2.4 and exam.layout?

Postby Stef Pillaert » Mon Jun 03, 2024 6:54 pm

Auwch!!!! I must have done something wrong in downloading this exam.layout file from Github. This file was completely rubish (looked like html). And the file that I used when using this "button" ad explained earlier, was a correct version (probably downloading it correctly the second time from github???).
So after putting the correct version at the correct location... everything is fine again.
I'm very, very, very sorry! :oops: :oops: :oops:
Stef


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 19 guests