LaTeX forum ⇒ LyXusthesis.layout / usthesis.lyx no longer working? Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Chavoux
Posts: 3
Joined: Sat Mar 30, 2019 9:15 pm

usthesis.layout / usthesis.lyx no longer working?

Postby Chavoux » Sat Mar 30, 2019 10:24 pm

Hi all,

I wrote my thesis using the usthesis class / layout / .lyx file, but can no longer export to .pdf (using pdflatex). My computer crashed and I had to re-install Linux (and all my programs, including LaTeX and LyX). Now, when trying to show/update pdf, I get the error message:
"Package babel Error: Unknown option `afrikaans'. Either you misspelled it (babel) or the language definition file afrikaans.ldf was not found."

"afrikaans" is one of the languages used by the usthesis class, but I cannot find it in CTAN or in the debian repository.

I suppose that I missed something during the re-installation of LyX / LaTeX?

Thanks in advance,
Chavoux

User avatar
Stefan Kottwitz
Site Admin
Posts: 9593
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Tue Apr 02, 2019 2:14 pm

Hi Chavoux,

welcome to the forum!

Perhaps you installed an older version of babel. Some version added Afrikaans support, a version of Dutch. (You could load Dutch instead)

Can you perhaps post your .log file here, as attachment? The Attachments link is below the text edit field, when writing a post.

Stefan
LaTeX.org admin

Chavoux
Posts: 3
Joined: Sat Mar 30, 2019 9:15 pm

Postby Chavoux » Tue Apr 02, 2019 5:07 pm

Hi Stefan,

Thanks for the welcome!

Attached is the Error message in LyX itself (as screenshot) and the output that shows when I click on "View Complete Log" (saved as pdfTeX.log). It looks like a Babel error to me (Line 178). Also attached the configure.log in my .lyx/ directory. I am not sure to which log file you refer?

As a workaround I could change the usthesis class / style / layout files so it does not require Afrikaans anymore, since I actually only need Afrikaans for a single page (the Summary/Abstract in Afrikaans) and my spelling and grammar of Afrikaans is good enough to do without the spell-checking, but I have no idea how to do this (in the usthesis.afr? usthesis.cls? usthesis.layout? usthesis.lyx? somewhere else?). Of course, then I will also have to do without the Afrikaans hyphenation, but for a single page, I can survive without it.

Thanks for the help. I think I might actually have a newer version of LyX now than before (when everything was still working), but I am not sure, since the laptop crashed.

Cheers
Chavoux
Attachments
configure.log
(75.94 KiB) Downloaded 104 times
pdfTeX.log
(152.43 KiB) Downloaded 103 times
LyX_error_20190402_164711.png
LyX_error_20190402_164711.png (211.38 KiB) Viewed 2354 times

Chavoux
Posts: 3
Joined: Sat Mar 30, 2019 9:15 pm

Postby Chavoux » Tue Jun 25, 2019 9:42 pm

I still have no idea exactly which package saved me... in the end I installed texlive-lang-all (500+ MB!) and my problem was fixed. I had texlive-lang-african, texlive-lang-english, and texlive-lang-other installed before, which did not solve my problem (although Afrikaans hyphenation is found in texlive-lang-other). I will later (once my thesis corrections are all done!) uninstall the texlive-lang-* packages one by one until I find the guilty party.

But this is just to help somebody else who might get stuck with this.

georgeo
Posts: 2
Joined: Fri Feb 14, 2020 1:25 pm

Postby georgeo » Fri Feb 14, 2020 1:27 pm

Chavoux wrote:I still have no idea exactly which package saved me... in the end I installed texlive-lang-all (500+ MB!) and my problem was fixed. I had texlive-lang-african, texlive-lang-english, and texlive-lang-other installed before, which did not solve my problem (although Afrikaans hyphenation is found in texlive-lang-other). I will later (once my thesis corrections are all done!) uninstall the texlive-lang-* packages one by one until I find the guilty party.

But this is just to help somebody else who might get stuck with this.


Did you have any luck finding out which package was needed?

georgeo
Posts: 2
Joined: Fri Feb 14, 2020 1:25 pm

Postby georgeo » Fri Feb 14, 2020 2:40 pm

It might be the texlive-lang-european package


Return to “LyX”

Who is online

Users browsing this forum: Google [Bot] and 4 guests