LaTeX forum ⇒ TeX Live and MacTeXEasy Installation of TeX Live on Ubuntu Topic is solved

Information and discussion about TeX Live distribution for all platforms (Windows, Linux, Mac OS X) and the related MacTeX: installing, updating, configuring
Site Moderator
Posts: 542
Joined: Sat Sep 01, 2012 6:38 am

Re: Easy Installation of TeX Live 2013 on Ubuntu

Postby scottkosty » Mon Nov 11, 2013 7:30 am

juanuni wrote:
Thanks. I have troubles with my O.S., but I solved this and I installed \TeXLive 2013 again without problems. Now, I have a litle problem. I use \TeXStudio like a \LaTeX editor, but I can't compile any LaTeX code.

I saw that I installed \TeXLive 2013 in /usr/local file. I suppose I should tell \TeXStudio the path for this to compile using \TeXLive 2013. How do I do that?

What do you mean by "can't compile" ? What error message do you get? Are you able to compile on the command line?


Posts: 24
Joined: Fri Nov 06, 2009 4:32 pm

Postby tonguim » Tue Aug 05, 2014 4:34 pm

I have updated TexLive on my Ubuntu 12.04 system yesterday.

After the updating process, when I tried to run the bibtex command, I got the following error
  1. bibtex: Not writing to ../chap1_introduction/chap1_introduction.blg (openout_any = p).
  2. I couldn't open file name `../chap1_introduction/chap1_introduction.blg'

I'm relating here the process I followed to fix the problem.

I already had TexLive-full installed on my Ubuntu 12.04 OS, and did installed this morning the 2014 TexLive as stated above to update my initial 2009 TexLive version.

So the OS found itself with 2 differents installation of latex.

After the second installation, I tried to normally compiled a bibtex file and got this error message:
  1. XXXX@IFTEaigny2:~/Phd/principal$ bibtex ../chap1_introduction/chap1_introduction
  3. bibtex: Not writing to ../chap1_introduction/chap1_introduction.blg (openout_any = p).
  4. I couldn't open file name `../chap1_introduction/chap1_introduction.blg'

After a long search on internet, I understood that the problem's cause is the presence of 2 differents version of latex on my OS. In consequence there were a conflict between the texmf.cnf file of both installation;
the first file texmf.cnf on my OS, ubuntu 12.04 is located here:
  1. /usr/share/texmf/web2c

the second file texmf.cnf on my OS, of the latest installation is located here:
  1. /usr/local/texlive/2014/texmf-dist/web2c

On both file, seek
  1. openout_any = p
where «p» is the paranoid setting. Change «p» in «r».

That fixed the problem on my side.

I got inspired by this website

Return to “TeX Live and MacTeX”

Who is online

Users browsing this forum: No registered users and 2 guests