LaTeX forum ⇒ TeX Live and MacTeXInstalling TeX Live 2010 from DVD (vs. TeX Live 2009)

Information and discussion about TeX Live distribution for all platforms (Windows, Linux, Mac OS X) and the related MacTeX: installing, updating, configuring
kalwisti
Posts: 8
Joined: Thu May 10, 2007 6:50 am

Installing TeX Live 2010 from DVD (vs. TeX Live 2009)

Postby kalwisti » Thu Nov 25, 2010 12:38 am

Hello, everyone,

After searching the forum, it seems this question has not been asked ... I am puzzled by the huge difference in installation times (from a DVD) between TeX Live (TL) 2010 and TL 2009: approx. 55 minutes for TL 2009 vs. approx. 7 minutes (!) for TL 2010. I'm wondering if anyone else has experienced this and could explain why there is such a marked difference. Did the TL gurus do something to reduce the package size and speed up the installation process?

Both TL .iso's were downloaded from a CTAN mirror in North America, their md5sum and sha256 sum were verified as correct prior to burning, and they were burned using the same CD/DVD optical drive. Also, they were installed on the same PC (although on different partitions); TL 2009 was installed in my CentOS 5.5 setup, and TL 2010 was installed in my Debian 6 (Squeeze) Xfce setup.

When I first tried installing TL 2010 last night, everything finished so quickly that I imagined something had gone wrong (despite the "successful install" message) ... However, when I checked, all the packages seemed to be there and the overall installation size was correct.

On my Debian setup, I finally gave up and installed TL 2009 from the official Debian repos because I ran into unexpected headaches correctly setting up the $PATH. (Debian apparently handles this differently than the other two distros in which I successfully installed TL from DVD). I Googled and Googled -- including a search here -- and tried several solutions but nothing worked. It was getting very late, I was frustrated and I quit. (Maybe I gave up too easily, but I decided that I didn't need a Ph.D. in the intricacies of $PATH setting and its post-modern interrelationships with bash, .bashrc and /etc/profile).

Thanks for any explanations you can provide; I'd like to understand what's going on.
=david

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am

Postby frabjous » Thu Nov 25, 2010 1:19 am

That does seem strange. Did you install the same scheme each time? (For what I mean by scheme, see here.)

If the system seems to be working fine, I wouldn't worry too much about it, though!

(It's hard to imagine setting the PATH variable could be that hard on Debian... if it becomes an issue again, do bring it up here, and I'm sure we could figure it out.)

kalwisti
Posts: 8
Joined: Thu May 10, 2007 6:50 am

Postby kalwisti » Thu Nov 25, 2010 8:09 am

Hi, frabjous,

Thank you for taking the time to reply; I appreciate it.

To answer your questions:

(1). Yes, I installed the same scheme each time. Each one was a "full install (everything)", and the only change I made before pressing the "I" key (to begin the installation) was to change the default paper type from A4 to letter.

With my seven-minute TL 2010 installation last night, the install-tl script reported that it installed 2133 packages. (That's why I thought there must have been a mistake). I did a spot-check of the packages, and they seemed to be in the correct place(s) in the TeX directory.

(2). Re: the PATH variable:

(a). In CentOS 5.5 (with TL 2009), setting it was easy; I followed the TeX Live documentation and pasted three lines at the end of my .bash_profile file:

  1. # Get the aliases and functions
  2. if [ -f ~/.bashrc ]; then
  3.     . ~/.bashrc
  4. fi
  5.  
  6. # User specific environment and startup programs
  7.  
  8. PATH=$PATH:$HOME/bin
  9.  
  10. export PATH
  11.  
  12. PATH=/usr/local/texlive/2009/bin/i386-linux:$PATH; export PATH
  13. MANPATH=/usr/local/texlive/2009/texmf/doc/man:$MANPATH; export MANPATH
  14. INFOPATH=/usr/local/texlive/2009/texmf/doc/info:$INFOPATH; export INFOPATH


Then I ran texhash as root, logged out and back in to my user account, followed the steps for configuring fonts for XeTeX use, and I was good to go.

(b). In Debian Squeeze (with TL 2010), things were not as straightforward. (I'm new to Debian, so my lack of familiarity may be a big part of the problem). Rather than a .bash_profile in the user's /home account, Debian appears to use a .profile file. The syntax of that file is different than what I saw in CentOS; the default structure is below:

  1. # ~/.profile: executed by the command interpreter for login shells.
  2. # This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
  3. # exists.
  4. # see /usr/share/doc/bash/examples/startup-files for examples.
  5. # the files are located in the bash-doc package.
  6.  
  7. # the default umask is set in /etc/profile; for setting the umask
  8. # for ssh logins, install and configure the libpam-umask package.
  9. #umask 022
  10.  
  11. # if running bash
  12. if [ -n "$BASH_VERSION" ]; then
  13.     # include .bashrc if it exists
  14.     if [ -f "$HOME/.bashrc" ]; then
  15.     . "$HOME/.bashrc"
  16.     fi
  17. fi
  18.  
  19. # set PATH so it includes user's private bin if it exists
  20. if [ -d "$HOME/bin" ] ; then
  21.     PATH="$HOME/bin:$PATH"
  22. fi


I was not sure exactly where to paste the PATH lines

  1. PATH=/usr/local/texlive/2010/bin/i386-linux:$PATH; export PATH
  2. MANPATH=/usr/local/texlive/2010/texmf/doc/man:$MANPATH; export MANPATH
  3. INFOPATH=/usr/local/texlive/2010/texmf/doc/info:$INFOPATH; export INFOPATH


so I tried several variant locations and structures, yet none worked properly ... After saving the change(s) to my .profile, I tried to run texhash but received an error message that the command couldn't be found.

I won't repeat every variation I tried, but the two I thought most likely to succeed were:

(+).
  1. [. . .]
  2. # set PATH so it includes user's private bin if it exists
  3. if [ -d "$HOME/bin" ] ; then
  4.     PATH="$HOME/bin:$PATH"
  5. PATH="PATH=/usr/local/texlive/2010/bin/i386-linux:$PATH; export PATH
  6. MANPATH=/usr/local/texlive/2010/texmf/doc/man:$MANPATH; export MANPATH
  7. INFOPATH=/usr/local/texlive/2010/texmf/doc/info:$INFOPATH; export INFOPATH"
  8. fi


($).
  1. [. . .]
  2. # set PATH so it includes user's private bin if it exists
  3. if [ -d "$HOME/bin" ] ; then
  4.     PATH="$HOME/bin:$PATH"
  5. fi
  6.  
  7. PATH=/usr/local/texlive/2010/bin/i386-linux:$PATH; export PATH
  8. MANPATH=/usr/local/texlive/2010/texmf/doc/man:$MANPATH; export MANPATH
  9. INFOPATH=/usr/local/texlive/2010/texmf/doc/info:$INFOPATH; export INFOPATH


I tried some other suggestions/tips I found from searching with Google, but my frustration -- and confusion -- level rose to the point where I decided to delete TL 2010 altogether and just install TL 2009 from the Debian repos. It's working fine and I'm grateful for that.

So, if you see an obvious error in what I tried with Debian, and you can offer a solution without spending a lot of your time on it, I'd appreciate knowing how to set the PATH in such an environment. It would be good to know for future reference, and it might help other users searching the Forum.

Thanks again for your help,
=david

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am

Postby frabjous » Thu Nov 25, 2010 8:26 am

I don't see why ($) shouldn't have worked. That's pretty much exactly what I have in my .profile (I'm using ArchLinux). (+) doesn't really make much sense, but might have worked nonetheless if you have a $HOME/bin folder. (It wouldn't if you don't.)

A change like this doesn't take effect immediately, however, so just adding these and then trying to run texhash wouldn't work. The .profile file is sourced when you log in, so you could log out and log back in or reboot. Or you could manually source .profile:

  1. source ~/.profile


but that would only affect the active shell, so rebooting or logging in/out might be better.

(You can tell from the comment there that it isn't sourced if .bash_login or .bash_profile exist, so make sure they don't -- or if they do, put the lines in there.)

Try the same three lines in your .bashrc if putting them in .profile doesn't work, assuming bash is your default shell.

Oh, and I should mention, you can bypass the need for changing your PATH altogether if you click the box that says "Create SymLinks to Binaries" or something like that on the TeXlive installer screen. (I can't remember exactly what the option is called.)

One last thing to remember. The first line is slightly different for 64 bit linux:

  1. PATH=/usr/local/texlive/2010/bin/x86_64-linux:$PATH; export PATH

kalwisti
Posts: 8
Joined: Thu May 10, 2007 6:50 am

Postby kalwisti » Thu Nov 25, 2010 9:35 am

Wow! Many thanks for the excellent tips. You Arch folks know your Linux well.

You've given me several options to try (and I may have been closer to a solution than I thought). I got thoroughly confused about the relationship between those .bash(...) files.

After last night's large TL 2009 download, I'm not inclined to uninstall it so that I can try with the TL 2010 DVD again on Squeeze. However, I do have some spare HD space to play around with, and the weekend is coming ... so I may experiment again. If I do, I'll report back on what happened.

Happy Thanksgiving to you and your family,
=david

User avatar
meho_r
Posts: 823
Joined: Tue Aug 07, 2007 5:28 pm

Postby meho_r » Thu Nov 25, 2010 2:15 pm

1. Regarding the long installation time, I experienced the same for TL2009 (have no idea why). However, there was a walkaround: I just mounted downloaded TL image instead of burning it on a DVD and installed it from there (installation from hard disk is much faster). A comparison: on my machine (with Debian Squeeze, 64bit), TL2009 installation from a DVD took about 40 minutes, while from a mounted TL .iso image it took about 4 minutes.

2. I solved PATH problem by simply adding the path to TL binaries to my PATH variable in ~/.profile. (And I'll repeat again what frabjous already noted, keep an eye on ~/.bash_login and/or ~/.bash_profile files: if they exist, your ~/.profile file will be ignored).

Here is the content of my ~/.profile file (I put the TL-related line at the end of the file):
  1. # ~/.profile: executed by the command interpreter for login shells.
  2. # This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
  3. # exists.
  4. # see /usr/share/doc/bash/examples/startup-files for examples.
  5. # the files are located in the bash-doc package.
  6.  
  7. # the default umask is set in /etc/profile; for setting the umask
  8. # for ssh logins, install and configure the libpam-umask package.
  9. #umask 022
  10.  
  11. # if running bash
  12. if [ -n "$BASH_VERSION" ]; then
  13. # include .bashrc if it exists
  14. if [ -f "$HOME/.bashrc" ]; then
  15. . "$HOME/.bashrc"
  16. fi
  17. fi
  18.  
  19. # set PATH so it includes user's private bin if it exists
  20. if [ -d "$HOME/bin" ] ; then
  21. PATH="$HOME/bin:$PATH"
  22. fi
  23.  
  24. PATH=/home/mehor/TeXLive/bin/x86_64-linux:/home/mehor/bin:/usr/local/bin:/usr/bin:/bin:/usr/games

After this change, log out and log in again and all should be set.

kalwisti
Posts: 8
Joined: Thu May 10, 2007 6:50 am

Postby kalwisti » Thu Nov 25, 2010 6:34 pm

meho_r wrote:2. I solved PATH problem by simply adding the path to TL binaries to my PATH variable in ~/.profile. (And I'll repeat again what frabjous already noted, keep an eye on ~/.bash_login and/or ~/.bash_profile files: if they exist, your ~/.profile file will be ignored).


Hi, meho_r,

Thank you for replying and for confirming that I haven't lost my mind. In my setup, I have only a ~/.profile file, so that should not be an issue. (I'm guessing it must be Debian's default because I did not change anything).

Your ~/.profile file will be helpful to use as a pattern -- although I notice that you installed TL into your /home directory. I would be keeping the default setting(s) suggested in the TL installation instructions.

Now I'm almost certain that the reason I ran into the "texhash not found" problem is because I did not log out and back again before I issued the texhash command.

Thanks again. Happy Thanksgiving to you and your family. (Now I'm off to help cook in the kitchen).

User avatar
sommerfee
Posts: 496
Joined: Mon Apr 09, 2007 4:20 pm

Postby sommerfee » Thu Nov 25, 2010 9:55 pm

I have installed TL2010 on Debian Squeeze too, and just installed it as root and selected the option to add symbolic links (to /usr/local/bin). Afterwards I did not have to adapt the PATH at all.

BTW: The is a section about "Vanilla TeX Live on Debian" on http://www.tug.org/texlive/debian.html. There is also a paragraph about setting the PATH on Debian system-wide.

kalwisti
Posts: 8
Joined: Thu May 10, 2007 6:50 am

Postby kalwisti » Fri Nov 26, 2010 8:08 am

Hi, sommerfee,

Thank you, too, for the helpful suggestions. The notes about setting up TL on Debian are good; I will read them carefully before I try installing TL 2010 again.

My experience with Squeeze has been smooth so far. There has not been a large volume of updates (maybe because I'm using Xfce [?]); I've accepted all update candidates proposed by Synaptic and they have all updated without problems. I don't know if it will continue this way but I have my fingers crossed.

User avatar
T3.
Posts: 208
Joined: Fri Mar 14, 2008 12:58 pm

Postby T3. » Sat Nov 27, 2010 10:50 am

kalwisti wrote:After searching the forum, it seems this question has not been asked ... I am puzzled by the huge difference in installation times (from a DVD) between TeX Live (TL) 2010 and TL 2009: approx. 55 minutes for TL 2009 vs. approx. 7 minutes (!) for TL 2010. I'm wondering if anyone else has experienced this and could explain why there is such a marked difference. Did the TL gurus do something to reduce the package size and speed up the installation process?


Yes, we did :) TeX Live 2010 is not longer "live", i.e., you can't run it directly from DVD any more. It was too big this year to fit on a single DVD, so we switched to compressed packaging, the same that we use also for over-the-network installations. The upside is what you observed: much quicker installation, because there is much less I/O on a DVD drive.

Cheers,

Tomek


Return to “TeX Live and MacTeX”

Who is online

Users browsing this forum: No registered users and 1 guest