LaTeX forum ⇒ TeX Live and MacTeXFedora with texlive, font msbm10.t3 not found Topic is solved

Information and discussion about TeX Live distribution for all platforms (Windows, Linux, Mac OS X) and the related MacTeX: installing, updating, configuring
Posts: 2
Joined: Sat Nov 13, 2021 3:20 pm

Fedora with texlive, font msbm10.t3 not found

Postby wrdlbrmpfd » Sat Nov 13, 2021 3:52 pm


I'm new on linux (Fedora35), and have a problem compiling my first document.
A minimal example looks like this:


pdflatex throws this error: "pdflatex (file msbm10.t3): cannot open Type 1 font file for reading"

No pdf is produced. I installed texlive by "dnf install texlive-scheme-full".

What I tried so far:

1) On another computer (opensuse) this document compiles, and a file msbm10.pfb is found. Its path is /net/TeXLive/2021/texmf-dist/fonts/type1/public/amsfonts/symbols/msbm10.pfb. On my system I found such a file as well, it's path is /usr/share/texlive/texmf-dist/fonts/type1/public/amsfonts/symbols/msbm10.pfb. It seems it is either not found, or the file with the ending .t3 is required instead.

2) When replacing \nless by \Re, the document is compiled correctly, reading a file /usr/share/texlive/texmf-dist/fonts/type1/public/amsfonts/cm/cmsy10.pfb. So it seems that the amsfonts directory is searched.

3) I found a file called "msbm10.t3" here: I downloaded it to the location of the msbm10.pfb-file, but nothing changed. I then found that such a file already exists on my system, in "/usr/share/texlive/texmf-dist/fonts/type3/mpfonts".

4) I tried "dnf install texlive-amsfonts.noarch" and "dnf install texlive-mpfonts.noarch", but both were installed already.

5) Following some advice in a similar situation i executed texhash.

6) I reinstalled texlive using "dnf reinstall texlive-scheme-full".

Now I'm out of ideas. Please let me know if you have any suggestions. Thanks a lot in advance :)

7) A friend could compile the document on his Fedora system. The file /usr/share/texlive/texmf-dist/fonts/type1/public/amsfonts/symbols/msbm10.pfb was read, which also exists on my system in the same location.
Last edited by Stefan Kottwitz on Sat Nov 13, 2021 6:57 pm, edited 1 time in total.
Reason: code marked

Recommended reading 2021: •
LaTeX Beginner's Guide LaTeX Cookbook
Posts: 2
Joined: Sat Nov 13, 2021 3:20 pm

Fedora with texlive, font msbm10.t3 not found  Topic is solved

Postby wrdlbrmpfd » Mon Nov 15, 2021 7:51 pm

It's working now, after pulling the latest Fedora update, and running updmap-sys at least twice :)

Before that I could compile using xelatex, I guess it's map was set correctly.

Return to “TeX Live and MacTeX”

Who is online

Users browsing this forum: No registered users and 2 guests