LaTeX forum ⇒ MiKTeX and proTeXtpdfcrop: The Perl script could not be found.

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
Posts: 5
Joined: Tue Jan 25, 2011 7:37 pm

pdfcrop: The Perl script could not be found.

Postby Ede_123 » Thu Aug 18, 2011 2:33 pm


I have a problem concerning pdfcrop.

When I call pdfcrop from commandline I get the following error:
  1. D:\>pdfcrop
  2. pdfcrop: The Perl script could not be found.
  3. pdfcrop: Data: scripts/pdfcrop/perl/

I'm using Windows7 x64, Miktex 2.9 (x86) and I installed Active Perl (x86).
The following files are present in my miktex installation:
C:\Program Files (x86)\TeX\MiKTeX 2.9\miktex\bin\pdfcrop.exe
C:\Program Files (x86)\TeX\MiKTeX 2.9\scripts\pdfcrop\

I also tried copying to
C:\Program Files (x86)\TeX\MiKTeX 2.9\scripts\pdfcrop\perl\
but it didn't change anything.

My PATH varialbe contains:
C:\Program Files (x86)\Perl\site\bin
C:\Program Files (x86)\Perl\bin
C:\Program Files (x86)\TeX\MiKTeX 2.9\miktex\bin

I allready tried calling the perl script directly. It works but produces another error (probably due to some path error)

Does anyone have an idea what's wrong with my setup of pdfcrop?
Last edited by Ede_123 on Fri Aug 19, 2011 9:01 pm, edited 1 time in total.

Posts: 5
Joined: Tue Jan 25, 2011 7:37 pm

Postby Ede_123 » Thu Aug 18, 2011 9:15 pm

Ok, I successfully broke pdfcrop on my laptop were it used to work before.
What I did was an update of MikTeX today. Yesterday everything worked ok...

Is there somebody who could assist me in locating the origin of the problem? Since I'm not too familiar with the internal structure of LaTeX it's quite complicated for me to track down what package update broke pdfcrop for me.

I assume first step would be to find what packages got updated and what version they were before. Is there a logfile somewehere, where the updates are written to?

Update 2:
Okay, I did it! pdfcrop is working again.

Problem seems, that pdfcrop.exe actually searches for in
MiKTeX 2.9/scripts/pdfcrop/perl/
but after the pdfcrop update to v1.32 from 2011/08/10 ist is just written to
MiKTeX 2.9/scripts/pdfcrop

My approach to copy into the subfolder /perl didn't work in the first place because I forgot to refresh file name database. (MiKTeX Options -> Refresh FNDB)

I'm going to refer this thread to Heiko Oberdiek, pdfcrops author. I assume he knows what to do, to resolve this problem in future versions.

Update 3:
Since it's probably an issue with MiKTeX and not with pdfcrop itself I created a bugreport here: ... tid=110783

User avatar
Stefan Kottwitz
Site Admin
Posts: 8595
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany

Postby Stefan Kottwitz » Thu Aug 18, 2011 10:42 pm

Thanks for the updates!

Site admin

Posts: 5
Joined: Tue Jan 25, 2011 7:37 pm

Postby Ede_123 » Fri Aug 19, 2011 9:00 pm

The bug has been fixed. The fix will be made available with the
next update cycle. You can watch the MiKTeX project page
for further information on the next update.

(From ... tid=110783)

Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 2 guests