LaTeX forum ⇒ Theses, Books, Title pagesLooking for the right LaTex version

Classicthesis, Bachelor and Master thesis, PhD, Doctoral degree
SerenaTex
Posts: 9
Joined: Tue Aug 01, 2017 12:03 pm

Looking for the right LaTex version

Postby SerenaTex » Tue Aug 01, 2017 12:34 pm

Hello, I found this good template to start writing my Master thesis.
However would like to use the template not as online version, but I have problem in installing the right LaTex -editor & compiler - for my MOC 10.8.5
Could you please give me an help ? (I have contacted by email the help system but no answer.. :/ )
Thank you very much !

User avatar
Johannes_B
Site Moderator
Posts: 3582
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Tue Aug 01, 2017 12:38 pm

Nobody knows what template you are talking about.
You already got a reply in the other thread.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

SerenaTex
Posts: 9
Joined: Tue Aug 01, 2017 12:03 pm

Postby SerenaTex » Tue Aug 01, 2017 12:49 pm

First thank you very much for the (double) answer!
The template I am speaking about is this one https://www.overleaf.com/10501796mjwjgx ... /39171186/

Regarding the problem in finding the version to download, I am looking for it since yesterday, and did not find a solution.
I got here ftp://ftp.tug.org/historic/systems/mactex
among which I should find the one for me.
I read somewhere that the version released till 2011 are ok on my OS 10.8
Therefore I get here
ftp://ftp.tug.org/historic/systems/mactex/2011/
where I stuck(!!) cause I don't know which one/which ones of these packages I need!

Any help from a more expert than me would be great .

SerenaTex
Posts: 9
Joined: Tue Aug 01, 2017 12:03 pm

Postby SerenaTex » Tue Aug 01, 2017 12:55 pm

Johannes_B wrote:Nobody knows what template you are talking about.
You already got a reply in the other thread.



First thank you very much for the (double) answer!
The template I am speaking about is this one https://www.overleaf.com/10501796mjwjgx ... /39171186/

Regarding the problem in finding the version to download, I am looking for it since yesterday, and did not find a solution.
I got here ftp://ftp.tug.org/historic/systems/mactex
among which I should find the one for me.
I read somewhere that the version released till 2011 are ok on my OS 10.8
Therefore I get here
ftp://ftp.tug.org/historic/systems/mactex/2011/
where I stuck(!!) cause I don't know which one/which ones of these packages I need!

Any help from a more expert than me would be great .

User avatar
Johannes_B
Site Moderator
Posts: 3582
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Tue Aug 01, 2017 1:00 pm

Off-topic: I wouldn't use the template. It is buggy.

If i understand you correctly, you want an old version of TeX Live? Why?
Nevermind, the template won't work with old systems and tge template won't workwith a very up to date installation. Some other updates broke internal code.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

SerenaTex
Posts: 9
Joined: Tue Aug 01, 2017 12:03 pm

Postby SerenaTex » Tue Aug 01, 2017 1:05 pm

Johannes_B wrote:Off-topic: I wouldn't use the template. It is buggy.

If i understand you correctly, you want an old version of TeX Live? Why?
Nevermind, the template won't work with old systems and tge template won't workwith a very up to date installation. Some other updates broke internal code.



Right, off topic. -sorry.
but ok, more clearly ...I need LaTex to write the thesis and cannot find what to install to start working... :?
I'm not very good and I am looking for help!

User avatar
Stefan Kottwitz
Site Admin
Posts: 8523
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue Aug 01, 2017 2:14 pm

You are right, the new MacTeX doesn't support older MAC OS versions. It's too inefficient to spend much effort on older systems used by a few users still, instead of investing that time in better support for newer versions. Basically, MacTeX supports OS X versions that are still supported by Apple.

I had the same issue on my Mac with OS X 10.9.5. I installed MacTeX 2017 on it, it did not work right away but it worked after I adjusted the path for compiling manually (where the executable binaries are located).

Perhaps ask on the MacTeX mailing list?

Besides this, you can post any LaTeX related question here.

Stefan
Site admin

SerenaTex
Posts: 9
Joined: Tue Aug 01, 2017 12:03 pm

Postby SerenaTex » Tue Aug 01, 2017 5:33 pm

Stefan Kottwitz wrote:You are right, the new MacTeX doesn't support older MAC OS versions. It's too inefficient to spend much effort on older systems used by a few users still, instead of investing that time in better support for newer versions. Basically, MacTeX supports OS X versions that are still supported by Apple.

I had the same issue on my Mac with OS X 10.9.5. I installed MacTeX 2017 on it, it did not work right away but it worked after I adjusted the path for compiling manually (where the executable binaries are located).

Perhaps ask on the MacTeX mailing list?

Besides this, you can post any LaTeX related question here.

Stefan


Since you have a Mac and you are into the topic, I take the chance to ask to you if it is worth to update the MOS to the last updating - Sierra- beside other possible reasons, also for the use of LaTex in a more straight forward and easy way.
Is it ?
I have always been told to keep the original OS ...but this might not be very worth anymore today.. ?!
many thanks again !

User avatar
Stefan Kottwitz
Site Admin
Posts: 8523
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue Aug 01, 2017 5:43 pm

Also I kept the OS version that I got with my laptop.

But yes, it's very recommendable to update to newer version once the own version got pretty old. If you are not very experienced with the Mac and updating a Mac, I would ask another skilled user to do it. But before, make a backup of all our personal data. And make sure that your hardware can run the new version.

Stefan
Site admin

User avatar
Johannes_B
Site Moderator
Posts: 3582
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Tue Aug 01, 2017 6:42 pm

We have some pretty old computers in the basement of of my institute at the university, they are running software needed for research. Software, that won't work on a recent computer or operating system.
My advice would be to check that first with the administrators.

My off-topic remark was concerning the (Masters/Doctoral thesis) template, not (La)TeX in general. The template needs some recent (two or three years) updates of LaTeX, but it will break with the very recent (last week) updates, due to some mistakes made by one of the maintainers.

The one responsible for the recent break is me, sorry for the inconvenience. On the other hand, i am not very fond of templates and encourage users not to use any templates.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “Theses, Books, Title pages”

Who is online

Users browsing this forum: No registered users and 2 guests