LaTeX forum ⇒ TeXworksInput Encoding

Information and discussion about TeXworks, an integrated LaTeX environment for several platforms
jakobkn
Posts: 2
Joined: Thu Apr 25, 2013 12:52 pm

Input Encoding

Postby jakobkn » Thu Apr 25, 2013 1:06 pm

Hello,

my TeXworks installation does not offer Latin 1 encoding as an optional encoding in editor options. I would like to have this due to collaboration with other people using TeXMaker editor with latin1 encoding (æøå characters are translated into �).

Does anyone know how TeXworks can be configured to do this? The version I'm using is that which is shipped with MiKTeX 2.9, fully updated. I imagined it would only be a matter of adding the appropriate .def file somewhere, but I have been unsuccessful thus far.

Any help appreciated!

Tags:

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Thu Apr 25, 2013 7:43 pm

jakobkn wrote:[…] my TeXworks installation does not offer Latin 1 encoding as an optional encoding in editor options. […]

It offers this encoding (ISO-8859-1) very well (see attachment). But it is suggestive to use Unicode (UTF-8). Nearly all other mordern editors off this encoding. So it should be no problem for your partners to recode their documents.


Best regards and welcome to the board
Thorsten
Attachments
TeXworks-r1285-Preferences-Editor-Encoding.png
TeXworks-r1285-Preferences-Editor-Encoding.png (75.35 KiB) Viewed 7891 times
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

jakobkn
Posts: 2
Joined: Thu Apr 25, 2013 12:52 pm

Postby jakobkn » Thu Apr 25, 2013 9:29 pm

Ah, thank you very much. I see now that I did not update the editor correctly when trying other ISO standards, and thus did not realize ISO-8859-1 = Latin1.

Adding % !TEX encoding = ISO-8859-1 to the beginning of files did the trick.

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Thu Apr 25, 2013 9:34 pm

jakobkn wrote:[…] Adding % !TEX encoding = ISO-8859-1 to the beginning of files did the trick.

Note that this solution is only occasional for the current document. But perhaps better in this situation.
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1


Return to “TeXworks”

Who is online

Users browsing this forum: No registered users and 1 guest