LaTeX forum ⇒ MakeIndex, Nomenclature, Glossaries and AcronymsGlossaries throwing error on very MWE Topic is solved

Information and discussion about MakeIndex - the tool to generate subject indices for LaTeX documents.
LeonardLopes
Posts: 11
Joined: Mon Nov 16, 2015 7:27 pm

Glossaries throwing error on very MWE

Postby LeonardLopes » Mon Nov 16, 2015 7:38 pm

I am trying to compile

  1. \documentclass{article}
  2. \usepackage{mfirstuc}
  3. \usepackage{glossaries}
  4. \begin{document}
  5. \end{document}


You can't get much more minimal than that. I followed the instructions for installing mfirstuc and glossaries from the CTAN website. I can confirm that they are located in /usr/share/texmf/tex/latex. When I try to perform the following:

pdflatex doc.tex

I get:

-bash-4.1$ pdflatex doc.tex
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
%&-line parsing enabled.
entering extended mode
(./doc.tex
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, arabic, basque, bulgarian, coptic, welsh, czech, slovak, german, ng
erman, danish, esperanto, spanish, catalan, galician, estonian, farsi, finnish,
french, greek, monogreek, ancientgreek, croatian, hungarian, interlingua, ibyc
us, indonesian, icelandic, italian, latin, mongolian, dutch, norsk, polish, por
tuguese, pinyin, romanian, russian, slovenian, uppersorbian, serbian, swedish,
turkish, ukenglish, ukrainian, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/glossaries/base/mfirstuc.sty (./etoolbox.sty
(/usr/share/texmf/tex/latex/etex/etex.sty)))
(/usr/share/texmf/tex/latex/glossaries/base/glossaries.sty
(/usr/share/texmf/tex/latex/base/ifthen.sty)
(/usr/share/texmf/tex/latex/xkeyval/xkeyval.sty
(/usr/share/texmf/tex/latex/xkeyval/xkeyval.tex
(/usr/share/texmf/tex/latex/xkeyval/keyval.tex)))
(/usr/share/texmf/tex/latex/textcase/textcase.sty)

! LaTeX Error: \mfirstucMakeUppercase undefined.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...

l.47 \renewcommand*{\mfirstucMakeUppercase}
{\MakeTextUppercase}%
?


I can see that it is loading mfirstuc and glossaries, but why is mfirstucMakeUppercase still undefined? Chasing down the mfirstucMakeUppercase call, it is located in glossaries.sty, version 4.18, 2015/09/09, line 47:
\renewcommand*{\mfirstucMakeUppercase}{\MakeTextUppercase}%

Any insight on this would be great!

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 3584
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Mon Nov 16, 2015 7:45 pm

Welcome,

your TeX distribution is ten years old. I would suggest to make an update and try again.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

User avatar
Stefan Kottwitz
Site Admin
Posts: 8529
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Mon Nov 16, 2015 10:35 pm

Hi Leonard,

welcome to the forum!

This version looks like TeX Live 2007, such as on Ubuntu 8.04 (Hardy Heron) or 8.10 (Intrepid Ibex) which are both not supported any more. I think you cannot simply update TeX. Also updating the operating system would be a good task. In such a case, i would backup all my personal data and make a new installation... but you may have reasons to stay with this Linux version for now.

Though, I assume that a TeX Live 2015 installation over the Internet, so independent from the Linux version, should work too on an older Linux.

Stefan
Site admin

LeonardLopes
Posts: 11
Joined: Mon Nov 16, 2015 7:27 pm

Postby LeonardLopes » Tue Nov 17, 2015 6:06 pm

I have uninstalled Tex Live 2007 and installed Tex Live 2015. However, when compiling the document, I still get

  1. This is pdfTeX, Version 3.141592-1.40.3 (Web2C 7.5.6)
  2. \write18 enabled.
  3. entering extended mode
  4. (./doc.tex
  5. LaTeX2e <2005/12/01>


Which is showing the 2005 LaTeX2e. Where is this file and is this the correct version?

Some more info on pdflatex:

  1. -bash-4.1$ pdflatex --version
  2. pdfTeX 3.14159265-2.6-1.40.16 (TeX Live 2015)
  3. kpathsea version 6.2.1
  4. Copyright 2015 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
  5. There is NO warranty. Redistribution of this software is
  6. covered by the terms of both the pdfTeX copyright and
  7. the Lesser GNU General Public License.
  8. For more information about these matters, see the file
  9. named COPYING and the pdfTeX source.
  10. Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
  11. Compiled with libpng 1.6.17; using libpng 1.6.17
  12. Compiled with zlib 1.2.8; using zlib 1.2.8
  13. Compiled with xpdf version 3.04


and my operating system:

  1. -bash-4.1$ cat /etc/*-release
  2. CentOS release 6.7 (Final)

LeonardLopes
Posts: 11
Joined: Mon Nov 16, 2015 7:27 pm

Postby LeonardLopes » Tue Nov 17, 2015 7:11 pm

Turns out that I was looking at an old file again and again. Now using 2015 version of latex2e. This 'ticket' can be closed.


Return to “MakeIndex, Nomenclature, Glossaries and Acronyms”

Who is online

Users browsing this forum: No registered users and 1 guest