LaTeX forum ⇒ BibTeX, biblatex and biberNo compilation output, no .sty file found Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Tom_EJ
Posts: 5
Joined: Mon Nov 21, 2016 4:33 pm

No compilation output, no .sty file found

Postby Tom_EJ » Wed Oct 25, 2017 1:54 pm

Dear community,

I installed a brand new OS, being Linux Mint 18.2, and wanted to start right away using LaTex but I face some odd new problems:

When I want to compile with LaTex or pdflatx or bibtex or whatsoever, there is no output in that little window that actually is supposed to appear at the bottom. So, it does simply not appear. Bewiderlingly, all the changes I make inside the text are shown correctly in the pdf document when I hit "quick build".

That happens when I use Texmaker.

In Texworks, the output at the bottom is generated when compiling, including some error messages and so forth.

However, in Texworks I get the message:
  1. I couldn't open style file natbib.bst
  2. ---line 57 of file class_QCA.aux
  3. : \bibstyle{natbib
  4. : }
  5. I'm skipping whatever remains of this command
  6. I found no style file---while reading file class_QCA.aux
  7. (There were 2 error messages)

Deliting the .aux file as suggested by some posts in the net has no result.

My settings:

  1. \documentclass[12pt,a4paper]{book}
  2. \usepackage[utf8]{inputenc}
  3. \usepackage[english]{babel}
  4. \usepackage{amsmath}
  5. \usepackage{amsfonts}
  6. \usepackage{amssymb}
  7. \usepackage{graphicx}
  8. \usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
  9. \usepackage[numbers]{natbib}
  10. \begin{document}
  11.  
  12. ....
  13.  
  14. \bibliographystyle{natbib}
  15. \bibliography{literature}
  16. \end{document}


I guess these are two seperate problems:
- the missing output of the compilations
- the problem with the .sty file

Generally, I installed the program using
  1. sudo apt-get install texlive-full

using the bash and
  1. sudo apt-get install texmaker

respectively.

I searched the net and the first problem seems to be well-known. Many posts suggest to ajust the path of pdflatex.exe...hm...it seems that such a file does not exist on my pc where is it supposed to be found?...I used

  1. find / -name pdflatex.exe

but got no results. Is my installation broken or incomplete?

Concerning the .sty file problem, I have no idea. It is supposed to work, like on my former OS, but it simply does not. The posts I found in the net are not ver satisfactory, so

I am thankful for any help, advice, or link that helps me out
:)
Linux Mint 18.2; KDE-Plasma5; 4.8.0-53-generic #56~16.04.1-Ubuntu x86_64 x86_64 x86_64 GNU/Linux
TeX 3.14159265 (TeX Live 2015/Debian) kpathsea version 6.2.1

User avatar
Johannes_B
Site Moderator
Posts: 3587
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Oct 25, 2017 2:13 pm

natbib is not a valid bibliographystyle, try plain instead.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Tom_EJ
Posts: 5
Joined: Mon Nov 21, 2016 4:33 pm

Postby Tom_EJ » Wed Oct 25, 2017 2:47 pm

Thanks, that worked at least for Texworks.
But the outcome is silly as there is no right quotation, e.g.:

Ragin, as he states himself, was trained "to use multivariate statistical techniques wherewer possible" [8, p.vii].


The "8" should actually be the reference...same output with \cite[p.vii]{Ragin1987} or \citep[p.vii]{Ragin1987}. The literature.bib sais:

  1. @Book{Ragin1987,
  2. Author = {Ragin, Charles},
  3. ALTauthor = {Ragin, Charles C.},
  4. ALTeditor = {•},
  5. title = {The Comparative Method. Moving Beyond Qualitative and Quantitative Strategies},
  6. publisher = {University of California Press},
  7. year = {1987},
  8. OPTkey = {•},
  9. OPTvolume = {•},
  10. OPTnumber = {•},
  11. OPTseries = {•},
  12. OPTaddress = {•},
  13. OPTedition = {•},
  14. OPTmonth = {•},
  15. OPTnote = {•},
  16. OPTannote = {•}
  17. }


In Texmaker, the change to the {plain} style has the same effect, despite that pdflatex does not generate a pdf file at all. Only quick build does the trick...
Linux Mint 18.2; KDE-Plasma5; 4.8.0-53-generic #56~16.04.1-Ubuntu x86_64 x86_64 x86_64 GNU/Linux
TeX 3.14159265 (TeX Live 2015/Debian) kpathsea version 6.2.1

User avatar
Stefan Kottwitz
Site Admin
Posts: 8544
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Wed Oct 25, 2017 3:16 pm

Hi Tom,

it may be below /usr/local/texlive/.

It's definitely not pdflatex.exe, since that's a Windows name, it should be only pdflatex. Check it with find again, and then try which pdflatex and which latex in the terminal to see if the system finds it.

Stefan
Site admin

User avatar
Johannes_B
Site Moderator
Posts: 3587
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Oct 25, 2017 6:27 pm

Try to replace plain with apalike and remove the numbers option when loading natbib.

The 8 is the number of the reference i guess (Vancouver style) but it seems you want Harvard style (author date). apalike is the only (very specific) author date style that comes to my mind, i use the modern package biblatex. If you are interested, please have a look at https://en.wikibooks.org/wiki/LaTeX/Bib ... _and_biber
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Tom_EJ
Posts: 5
Joined: Mon Nov 21, 2016 4:33 pm

Postby Tom_EJ » Wed Oct 25, 2017 6:51 pm

Thanks a lot to all those who helped! Now it works.

First: In linux mint the pdflatex file is in /usr/bin/pdflatex
It can be easily found with the help of the bash by typing:

  1. find / -name pdflatex


(Thank you Stefan, of cause it has to be written without .exe ...sorry for mindless copy and paste from other sources :roll: )
or simply

  1. which pdflatex


I soved also the .sty problem: Indeed I was confused about Vancouver and Harvard style, and indeed I wanted to have the Harvad one, for me worked
  1. [...]
  2. \usepackage{natbib}
  3. \usepackagr{har2nat}
  4. [...]
  5. foo
  6. [...]
  7. \bibliographystyle{agsm}
  8. [...]


apalike instaed of agsm works as well, thanks, Johannes. And thanks for the hint with [numbers], I thought this would only generate numbers in front of the listing of the bibliography, and not inside the running text - but appearently it does...something I learned today!

Now the most embarissing part: If you ever wonder why there is no output in the little window below while compiling...have a look at the "Message / Log" button on the left below...it might be simply switched off...yea..sorry... :oops:

I hope that helps some day some other fool like me,
have a good night, thread can be closed :)
Linux Mint 18.2; KDE-Plasma5; 4.8.0-53-generic #56~16.04.1-Ubuntu x86_64 x86_64 x86_64 GNU/Linux
TeX 3.14159265 (TeX Live 2015/Debian) kpathsea version 6.2.1


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 1 guest