LaTeX forum ⇒ BibTeX, biblatex and biberbiblatex-chicago citations in parentheses Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
ExecutorElassus
Posts: 79
Joined: Wed Sep 07, 2011 3:14 pm

biblatex-chicago citations in parentheses

Postby ExecutorElassus » Fri Sep 22, 2017 3:51 pm

Hi Forum,

I have Lyx, working on a fairly large document with a lot of citations, using biblatex-chicago, with biber as the backend. In the Document Settings, I have Lyx set to use Natbib with Author-year style. In my preamble, I have the following relevant code:

  1. \usepackage[notes,natbib,backend=biber,alldates=edtf,idemtracker=context,ibidtracker=context,dateabbrev=false,language=american]{biblatex-chicago}
  2. \renewcommand{\citet}[1]{\autocite{#1}}
  3. \addbibresource{/home/user/bookbib.bib}

At the end of the document I have the link to the .bib file hidden within a Lyx note, followed by \singlespacing and \printbibliography (I was given to understand this is necessary to use biblatex properly, though that was a while ago).

My question is this: In my document, citation entries are all enclosed within parentheses. How can I change this? I'd like it to follow the regular CMS style, in which citations are just plain un-parentheses-enclosed citations.

Do I have something here set up wrong?

Thanks for the help,

EE

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 3587
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Sep 22, 2017 5:31 pm

You renewed citet to be autocite. Usually, oe would use autocite in the document and tell biblatex what to use for those cites.
Try the biblatex options autocite=plain or autocite=inline.

If this is not helpful, please provide a minimal working example so we can reproduce your issue.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

ExecutorElassus
Posts: 79
Joined: Wed Sep 07, 2011 3:14 pm

Postby ExecutorElassus » Fri Sep 22, 2017 7:51 pm

There's something more going on here. My main document has a lot of child documents, and some of them have correct citations. I'm going to dig through their respective Document Settings and see if I can track it down.

Stay tuned.

ExecutorElassus
Posts: 79
Joined: Wed Sep 07, 2011 3:14 pm

Postby ExecutorElassus » Fri Sep 22, 2017 10:57 pm

Found the issue. The main document is just a container for a lot of child documents, but only the master document has a preamble and the basic formatting stuff. However, since that document's Document Settings profile is also the default, they all get copied over when I create new documents as child documents. My problem was that some of those child documents still had an entry -- in my case, "plainnat" or "natbib" -- in the "Default Style" field under Document Settings --> Bibliography. Also, some children had "numerical" selected in the dropdown next to the Natbib citation style.

Once I cleared the "Default style" entry and set the Natbib style to "author-year," the citations went back to being normal.

I think maybe this is a general issue with Lyx having a page in its Settings for specifying citation styles that can't be left completely blank, yet needing a bunch of stuff custom-input in the preamble to use (as in my case) biblatex-chicago. You get cross-talk if you aren't careful about clearing all that stuff out of child documents, and weird, unexpected behavior if the settings are wrong.

So now I'll go back through all the child documents and make sure their Bibliography sections are properly cleared.

Thanks for forcing me to do some investigation.

Cheers,

EE


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 1 guest