LaTeX forum ⇒ BibTeX, biblatex and biberBibTeX Run creates flawed Bibliography Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Posts: 2
Joined: Fri Feb 01, 2013 5:27 pm

BibTeX Run creates flawed Bibliography

Postby Homeberw » Fri Feb 01, 2013 5:50 pm

Hi all,

I have a document with an associated *.bib file that I have typeset successfully with MiKTeX using the WinEdt front end. On another computer, I decided to try out TeXworks. Using WinEdt, I do "bibtex -> latex -> latex" and all the references come out with no problem. Using TeXworks, when i run BibTeX (no errors) and then PDFLaTeX, I get this error:
  1. ! LaTeX Error: Something's wrong--perhaps a missing \item.
  2. See the LaTeX manual or LaTeX Companion for explanation.
  3. Type H <return> for immediate help.
  4. ... l.24 \end{thebibliography}

So, in trying to figure out the problem, I notice that while BibTeX doesn't give an error with TeXworks, there are no \bibitem entries in the .bbl file. When I copy the .bbl from the WinEdt machine (which does have all the \bibitem entries), then two runs of PDFLaTeX works fine. I am sure I'm doing something stupid, but can anyone give a suggestion?


Posts: 2
Joined: Fri Feb 01, 2013 5:27 pm

Postby Homeberw » Fri Feb 01, 2013 8:20 pm

Problem solved. Updated to use the latest IEEEtran syle and bst files. Everything working now. Hope I didn't waste anyone's time.

Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 3 guests