LaTeX forum ⇒ GeneralMissing \endcsname inserted Topic is solved

LaTeX specific issues not fitting into one of the other forums of this category.
Natasz
Posts: 3
Joined: Thu Aug 04, 2011 6:05 pm

Re: Missing \endcsname inserted

Postby Natasz » Wed Aug 24, 2011 4:26 pm

Hi,

I have a similar problem. Here's my text:

  1. ... is analysed not as a property, but as a relation \autocite[2]{yanalita}
  2. %check page number and the theories differ in ...


Here's the error:

  1. ! Missing \endcsname inserted.
  2. <to be read again>
  3. \unhbox
  4. 1.19 ..., but as a relation \autocite[2]{yanalita}
  5.  
  6. ?


Here's my preamble:

  1. \documentclass[a4paper,12pt]{report}
  2. \usepackage{abstract}
  3. \usepackage[UKenglish]{babel}
  4. \usepackage[ansinew]{inputenc}
  5. \usepackage{csquotes}
  6. \usepackage[dvips]{color}
  7. \usepackage[T1]{fontenc}
  8. \usepackage{amsmath}
  9. \usepackage{amsthm}
  10. \usepackage{amsfonts}
  11. \usepackage{etex}
  12. \usepackage{mathrsfs}
  13. \usepackage{fancyhdr}
  14. \usepackage{graphicx}
  15. \usepackage[active]{srcltx}
  16. \usepackage{setspace}
  17. \usepackage{stmaryrd}
  18. \usepackage[all]{xy}
  19. \usepackage{hyperref}
  20. \usepackage{url}
  21. \usepackage{etoolbox}
  22. \usepackage{logreq}
  23. \usepackage{ifxetex}
  24. \usepackage{keyval}
  25. \usepackage{ifthen}
  26. \usepackage[bibstyle=authoryear, citestyle=authoryear-icomp, natbib=false, isbn=false, url=false, doi=false] {biblatex}
  27. \usepackage{a4wide}
  28.  
  29. \renewcommand{\chaptermark}[1]{\markright{#1}}
  30. \renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}
  31. \title{TITLE}
  32. \author{NAME}
  33. \date{2012}
  34. \bibliography{../simon-bibliography}
  35. \begin{document}


I also attach the log file. It seems quite clearly to be a problem with the quotation, and seems to have nothing to do with 'Usage of a backslash in front of the name of an environment, e.g \begin{\itemize}'
Any ideas?
Attachments
PhD.log
(28.78 KiB) Downloaded 141 times

Tags:

JacobB
Posts: 1
Joined: Tue May 01, 2012 2:50 pm

Postby JacobB » Tue May 01, 2012 3:00 pm

Hi,

I know this post i quiet old, but it is one of the first hits on google when you search for the error "Missing \endcsname inserted", and it doesn't fix the error.

For a solution to the original post (and to my students problem) the error can be averted by avoiding the use of non-english characters in the \label and \ref commands.

User avatar
Stefan Kottwitz
Site Admin
Posts: 8522
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue May 01, 2012 4:05 pm

Hi Jacob,

welcome to the board!

Thanks for adding the information. Probably the error may be caused by different issues. I wish posters would provide the code, so we could see and fix the problem. Often they don't do, so we ask to see the .log file at least, to get some information, as here.

If you look below (when logged in), there's a list of similar topics, I hope one of those also might help if somebody comes here via google.

Feel free to answer any of the (possibly older) unanswered or unsolved questions, if you like. ;-) Like you already did above, it helps further visitors.

Stefan
Site admin

jaydeepsb
Posts: 1
Joined: Mon Jul 16, 2012 11:32 am

Postby jaydeepsb » Mon Jul 16, 2012 11:38 am

Hello,

My problem is "solved", by just deleting all the Aux. files.
i.e. .aux, .brf, .out, .synctex.gz, .toc
hope, it helps to others as well.

LaTeXist
Posts: 1
Joined: Fri Feb 07, 2014 6:52 am

Postby LaTeXist » Fri Feb 07, 2014 6:59 am

Hi,
I got the same problem. Solved it by removing letters of foreign language in "\cite{what€ver}" (or it could also be an inappropriate symbol ex. "}")

Regards
LaTeXist

Miska
Posts: 1
Joined: Fri Jun 13, 2014 5:09 pm

Postby Miska » Fri Jun 13, 2014 5:11 pm

I got this error "Missing \endcsname inserted" when I accidentally put "~" into a label.


Return to “General”

Who is online

Users browsing this forum: No registered users and 10 guests