LaTeX forum ⇒ GeneralGlossary not printed Topic is solved

LaTeX specific issues not fitting into one of the other forums of this category.
Scorpion
Posts: 12
Joined: Sun May 05, 2013 10:37 pm

Glossary not printed

Postby Scorpion » Tue Jun 11, 2013 8:29 pm

Hey,

I use the package glossaries in this way.
  1. \usepackage[acronym,toc]{glossaries}

It works so far in the text, but now at the end of my thesis I wanted to print it out.
  1. \printglossary[type=\acronymtype,title=XXX,nonumberlist=true,toctitle=XXX, style=altlong4colwithindent]

But it just prints out an empty page and there is also no entry in the ToC. The style works, because I already used this for the bachelors thesis and that's why I have almost no idea how I can make it work!

The only thing I can think of is that I have to put some parameters to MakeIndex but when I try this (in TeXnicCenter) I just get errors.
  1. -s "%tm.ist" -t "%tm.alg" -o "%tm.acr" "%tm.acn"

I really need help because I have to submit in two days and I have no clue how to fix it. :(

Tags:

User avatar
cgnieder
Site Moderator
Posts: 1974
Joined: Sat Apr 16, 2011 7:27 pm
Location: Germany
Contact:

Postby cgnieder » Tue Jun 11, 2013 8:32 pm

Can you please post a Infominimal working example that let's us reproduce your issues?

Regards
Clemens
------------------------------
chemmacros · chemformula · leadsheets · xsim

Scorpion
Posts: 12
Joined: Sun May 05, 2013 10:37 pm

Postby Scorpion » Tue Jun 11, 2013 9:15 pm

  1. \documentclass[
  2. 11pt,
  3. a4paper,
  4. % draft, % draft=entwurf
  5. % normalheadings,
  6. listof=totoc,
  7. bibliography=totoc, % Bibliographie ins ToC
  8. ]{scrreprt}
  9. \usepackage[acronym, toc]{glossaries}
  10.  
  11. \renewcommand*{\glspostdescription}{}
  12. \makeglossaries
  13.  
  14. \newacronym{123}{123}{1234567890}
  15.  
  16. \newcommand*{\myglossaryindent}{0.65cm}
  17. \newcommand*{\myglsdescwidth}{10cm}
  18. \newglossarystyle{altlong4colwithindent}
  19. {
  20. \glossarystyle{altlong4col}
  21. \renewenvironment{theglossary}
  22. {\begin{longtable}[l]{@{\hspace{\myglossaryindent}}lp{\myglsdescwidth}lp{\glspagelistwidth}@{}}}
  23. {\end{longtable}}
  24. }
  25.  
  26. \begin{document}
  27.  
  28. \tableofcontents
  29.  
  30. \chapter{chapter 1}
  31. text \gls{123}.
  32.  
  33. \printglossary[type=\acronymtype, title=Abkürzungen, nonumberlist=true, toctitle=Abkürzungen, style=altlong4colwithindent]
  34.  
  35. \end{document}

User avatar
cgnieder
Site Moderator
Posts: 1974
Joined: Sat Apr 16, 2011 7:27 pm
Location: Germany
Contact:

Postby cgnieder » Tue Jun 11, 2013 10:59 pm

When I copied you code to a file test.tex and compiled
  1. with pdflatex (pdflatex test)
  2. with makeglossaries (makeglossaries test)
  3. with pdflatex (pdflatex test)
everything looks as I expect it to... no errors and the acronym shows up in the list as it should.

Regards
Clemens
------------------------------
chemmacros · chemformula · leadsheets · xsim

Scorpion
Posts: 12
Joined: Sun May 05, 2013 10:37 pm

Postby Scorpion » Tue Jun 11, 2013 11:21 pm

omg.... the problem was the "ü" i had in the title of the glossaries :shock:

User avatar
cgnieder
Site Moderator
Posts: 1974
Joined: Sat Apr 16, 2011 7:27 pm
Location: Germany
Contact:

Postby cgnieder » Tue Jun 11, 2013 11:39 pm

Did you run the makeglossaries program on the file? You said something about makeindex (which works but makeglossaries tales care of any needed options, style files, ...).

Regards
Clemens
------------------------------
chemmacros · chemformula · leadsheets · xsim

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Wed Jun 12, 2013 9:46 am

A corresponding Know How Article might help here.


Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

User avatar
cgnieder
Site Moderator
Posts: 1974
Joined: Sat Apr 16, 2011 7:27 pm
Location: Germany
Contact:

Postby cgnieder » Wed Jun 12, 2013 9:49 am

Scorpion wrote:omg.... the problem was the "ü" i had in the title of the glossaries :shock:


That's strange: your example compiled for me just fine -- including the “ü”
Clemens
------------------------------
chemmacros · chemformula · leadsheets · xsim


Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 8 guests