LaTeX forum ⇒ Fonts & Character Setsproblem using PostScript fonts Topic is solved

Information and discussion about fonts and character sets (e.g. how to use language specific characters)
ravindasenarath
Posts: 3
Joined: Wed Feb 22, 2012 5:52 pm

problem using PostScript fonts

Postby ravindasenarath » Wed Feb 22, 2012 5:58 pm

Hi,

I'm a beginner to latex. I'm using PostScript fonts in my latex code as follows.

  1. \usepackage{times,mathptmx,courier}
  2. \usepackage[scaled=.92]{helvet}
  3. \usepackage{pifont}


when compiling it produce error as follows.

kpathsea: Running

mktextfm

ptmr7t

mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ptmr7t

This is METAFONT, Version 2.718281 (TeX Live 2009/Debian)

kpathsea: Running

mktexmf

ptmr7t

! I can't find file `ptmr7t'. <*> ...:=ljfour; mag:=1; nonstopmode; input ptmr7t Please type another input file name ! Emergency stop. <*> ...:=ljfour; mag:=1; nonstopmode; input ptmr7t Transcript written on mfput.log.

grep: ptmr7t.log: No such file or directory

mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ptmr7t' failed to make ptmr7t.tfm.

kpathsea: Appending font creation commands to missfont.log.



how can I eliminate this problem and use PostScript fonts successfully with latex?

Thank you

User avatar
Stefan Kottwitz
Site Admin
Posts: 8039
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Wed Feb 22, 2012 6:32 pm

Hi,

welcome to the board!

Install the times package, because ptmr7t belongs to it.

Stefan
Site admin

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Wed Feb 22, 2012 6:35 pm

The times package is obsolete. Just drop it. You've got Times support by the mathptmx package. Another alternative is to use the txfonts package.


Best regards and welcome to the board
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

User avatar
Stefan Kottwitz
Site Admin
Posts: 8039
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Wed Feb 22, 2012 6:38 pm

Sometimes I don't remember, which is the obsolete one of times and txfonts. :-)

Stefan
Site admin

ravindasenarath
Posts: 3
Joined: Wed Feb 22, 2012 5:52 pm

Postby ravindasenarath » Thu Feb 23, 2012 6:48 am

Thanks for the information but I'm still struggling. The package mathptmx and others were given depending with a distribution(MiKTeX and Tex Live). I'm using Texmaker on Ubuntu 10.04. So ?? :(

User avatar
Stefan Kottwitz
Site Admin
Posts: 8039
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Thu Feb 23, 2012 9:42 am

Remove the times package from your document preamble.

If you still need the ptmr7t font, install the Ubuntu package texlive-fonts-recommended.

Stefan
Site admin

ravindasenarath
Posts: 3
Joined: Wed Feb 22, 2012 5:52 pm

Postby ravindasenarath » Thu Feb 23, 2012 1:09 pm

Got it solved. :)

Installing texlive-fonts-recommended from a separate package didn't work. Finally install one that was in the ubuntu software channel work for me.

Thanks Stefan_K and localghost :)


Return to “Fonts & Character Sets”

Who is online

Users browsing this forum: No registered users and 1 guest