LaTeX forum ⇒ DevelopmentTeXnicCenter 2.0 Alpha 1 - Issues

Information and discussion about the TeXnicCenter development. This is the place to go for TeXnicCenter core and wizard developers.
Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Re: TeXnicCenter 2.0 Alpha 1 - Issues

Postby Sergiu » Wed Oct 28, 2009 11:21 pm

Fix commited. Thanks for the report.
TeXnicCenter Developer
http://www.texniccenter.org/

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Thu Oct 29, 2009 3:01 am

Sergiu wrote:Fix commited. Thanks for the report.

Well, thanks to you! It seems that this project is doing extremely well and that its completion is not very far.

U-Jean
Posts: 20
Joined: Tue Sep 08, 2009 3:16 pm

Postby U-Jean » Thu Oct 29, 2009 12:12 pm

@Martin
are you sure that those warnings are not related to warnings by the parser?
What happens if you click on those buttons?
I have those icons activated too without having any warnings after compilation, but the parser issues some warnings because it does not find the included graphics since I'm using the "\graphicspath{{graphics/}}" command in the header.

This is actually a small bug / feature request by itself ...

Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Postby Sergiu » Thu Oct 29, 2009 3:52 pm

Martin's observation was correct: TeXnicCenter didn't clear the internal parse state after an open project had been closed hence the warning buttons remained active.
TeXnicCenter Developer
http://www.texniccenter.org/

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Thu Oct 29, 2009 3:56 pm

Sergiu wrote:Fix commited. Thanks for the report.

I just tried it again and the fix does not seem to work. I still get the warning icons activated. When I click it, it goes somewhere in some file. One of the places it seems to always go at "\end{document}" in the main file.

U-Jean
Posts: 20
Joined: Tue Sep 08, 2009 3:16 pm

Postby U-Jean » Thu Oct 29, 2009 4:01 pm

@Sergiu
My observation is to the contrary. Using the official Alpha1 on WinXP:
After opening my project the buttons are activated because the parser cannot find my graphics.
After compilation with no warnings the warning buttons are deactivated.

Edit: Confirming the post below that the issue seems to be related to the build window being anchored. I had it on auto-hide.
Last edited by U-Jean on Thu Oct 29, 2009 4:20 pm, edited 1 time in total.

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Thu Oct 29, 2009 4:08 pm

Ok, I remarked that the "warning icons" problem is related to the build panel. When it is set to auto-hide, it is ok. When it is set to "anchored", I have this problem.

Sergiu
Posts: 63
Joined: Mon May 12, 2008 1:21 pm

Postby Sergiu » Thu Oct 29, 2009 4:55 pm

I committed a fix which hopefully corrects the inconsistent behavior. Previous/next warning buttons will be enabled depending whether the Parse or one of the Error List panes is activated.
TeXnicCenter Developer
http://www.texniccenter.org/

U-Jean
Posts: 20
Joined: Tue Sep 08, 2009 3:16 pm

Postby U-Jean » Thu Oct 29, 2009 6:38 pm

New issue: spell check does not work for the text after any command with those swung braces {}.

e.g. This is a test.\footnote{test} tesst

tesst is not recognized as being misspelled.

this works also if you just put {} anywhere in the text, the spellcheck system is only activated again after a line break.

probably related to the known issue/feature
Spell check does not work inside braces {}.

sanji
Posts: 9
Joined: Sat Oct 24, 2009 6:20 pm

Postby sanji » Thu Oct 29, 2009 9:05 pm

Sergiu wrote:Problem fixed. TeXnicCenter will respect the above group policy not only for recent documents but also recent projects.
Thanks!

I think I know why it compiled without errors in the other user account:
I created the other account just (be)for(e) the compilation and after I installed the Windows 7 SDK, so that its registry entries were filled with correct values, so there was no need for the bugfix mentioned by MartinC.


Return to “Development”

Who is online

Users browsing this forum: No registered users and 1 guest