LaTeX forum ⇒ GeneralNo change in output

General information and discussion about TeXnicCenter
barbarianzap
Posts: 5
Joined: Mon Jun 21, 2010 5:09 pm

No change in output

Postby barbarianzap » Mon Jun 21, 2010 5:18 pm

Hi all.
I have a problem with TexnicCenter 1.0 RC1.
Someone gave me a 'template' project. I was supposed to just change the text and everything would be fine. The project generates output as it is, but, if I make any changes in the files, the output is the same. The tex files, when opened in other text-editors, do have the text changed. I even sent the project to another computer and the result remains the same.
Is there some way that the files are 'locked' ? Although I don' know why that person would lock the files since she knew that I was about to edit them.

Looking forward for your replies.
Thanks.
Last edited by barbarianzap on Mon Jun 21, 2010 8:09 pm, edited 1 time in total.

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am
Location: Amherst, MA

Postby frabjous » Mon Jun 21, 2010 5:30 pm

Did you run latex or pdflatex on the .tex file after you changed it?

Can you explain what you mean when you say “project generates output as it is”—is there a script you’re supposed to run to reprocess the .tex file or something?

barbarianzap
Posts: 5
Joined: Mon Jun 21, 2010 5:09 pm

Postby barbarianzap » Mon Jun 21, 2010 5:47 pm

No, I didn't run. I thought this is done automatically. Am I supposed to this manually every time I change the files?

I meant it produced the output it was intended to in the first place. But if I changed the text, it didn't change the text in the output file.

I attached the project, if you would be kind enough to help me.
The text language is romanian, but the problem is pretty obvious: in the 'intro.tex' file, I added some random text ( awafwafwafwa ) that doesn't show up in the pdf output. Of course, I'm not interested in that random text, but neither do other words show up in the output.

Thanks.
no output example.zip
(193.47 KiB) Downloaded 138 times

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm
Contact:

Postby josephwright » Mon Jun 21, 2010 6:24 pm

barbarianzap wrote:No, I didn't run. I thought this is done automatically. Am I supposed to this manually every time I change the files?

Yes.
barbarianzap wrote:The text language is romanian, but the problem is pretty obvious: in the 'intro.tex' file, I added some random text ( awafwafwafwa ) that doesn't show up in the pdf output. Of course, I'm not interested in that random text, but neither do other words show up in the output.

Works fine for me.
Joseph Wright

barbarianzap
Posts: 5
Joined: Mon Jun 21, 2010 5:09 pm

Postby barbarianzap » Mon Jun 21, 2010 6:36 pm

Well I am using the profile "Latex -- > PDF " and I've got in the options menu "Run latex in this profile" with the "pdflatex.exe's path set. Why doesn't it run automatically? Isn't this what that profile setting ought to do ?
And how can I run it manually? TC doesn't have a very useful context menu for the files in the project.

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Mon Jun 21, 2010 7:10 pm

barbarianzap wrote:[...] Why doesn't it run automatically? Isn't this what that profile setting ought to do ?
And how can I run it manually? TC doesn't have a very useful context menu for the files in the project.

What makes you think so? Who told you that? Or is this just an assumption? TeXnicCenter (TXC) has a help function where you can read about the handling. Move the mouse over the icon bar and you will get a quick info about the buttons. Files outside a project are compiled by pressing Ctrl+F7. For a document (master file) inside a project it only requires F7. If TXC is not comfortable enough for you, try another editor. And by the way you can report if you have found one that masters automatic compilation.


Best regards and welcome to the board
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

barbarianzap
Posts: 5
Joined: Mon Jun 21, 2010 5:09 pm

Postby barbarianzap » Mon Jun 21, 2010 7:19 pm

I was talking about the context menu: when you click a file in project view, visual studio, netbeans, eclipse etc, have an option like 'compile' or something like that.
And I am building output ( pressing f7 ) but I don't get a different output. It's like the Latex doesn't see that the files are changed. It keeps outputting the same PDF as before making changes.
Thank you for your support, but I still can't modify the final output. Any other ideas?

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Mon Jun 21, 2010 7:48 pm

barbarianzap wrote:I was talking about the context menu: when you click a file in project view, visual studio, netbeans, eclipse etc, have an option like 'compile' or something like that. [...]

You can't compare TXC with those kinds of editor. But your idea may be worth a note to the developers of TXC with a feature suggestion in our development forum [1]. This then may find its way into TXC2. But I think pressing a key is much faster than always grabbing the mouse, open this menu and choose the according entry.
barbarianzap wrote:[...] And I am building output ( pressing f7 ) but I don't get a different output. It's like the Latex doesn't see that the files are changed. It keeps outputting the same PDF as before making changes. [...]

If you are using the Adobe Reader as your PDF viewer you should know that it locks the opened file thus prevents it from being overwritten. Perhaps another viewer is better which doesn't do so.

On my Linux system your project compiles smoothly. At the moment I can't test your project with TXC because I'm primarily using Linux as my operating system. Perhaps later this day or tomorrow. I can only give you the advice to use the babel package to get the right hyphenation and all the names (bibliography, chapter, ...) in the Romanian language. And regarding your setup for the page layout you should take a look at our topic about obsolete classes and packages [2]. Furthermore you are using old LaTeX2.09 syntax for font styles in some of your short definitions. But you are working with LaTeX2e.

[1] View forum: Feature Suggestions
[2] View topic: Obsolete packages and document classes - Avoid usage!
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am
Location: Amherst, MA

Postby frabjous » Mon Jun 21, 2010 7:51 pm

I don't have TeXnicCenter installed (--I don't use Windows, but linux--) so I don't remember what F7 does, but it should update when you hit "compile" or "build".

Anyway, I ran pdflatex on your main.tex, and the nonsense word is showing up. (fwafawawgawgwg) I'm attaching the PDF so you can see it.

If TXC isn't working, try running pdflatex.exe from the command line on the file main.tex two or three times, and see if the output changes. If not, post the output and log file here.
Attachments
main.pdf
(127.18 KiB) Downloaded 224 times

barbarianzap
Posts: 5
Joined: Mon Jun 21, 2010 5:09 pm

Postby barbarianzap » Mon Jun 21, 2010 8:08 pm

It sure wasn't Adobe's fault. I had the Reader closed and even moved the whole project on a different computer so that was out of the question.

Anyway, I did compile it from the command line and after a few errors, it prompted that it needs some updates downloaded. I downloaded them and the output was right this time. After this, TC works too, obvious.

Apparently I didn't have some packages and that caused me trouble. The bad thing is that TC didn't say anything. Oh well, in the end all works well.

Thank you guys.


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests