LaTeX forum ⇒ GeneralMake Yap default DVI Viewer in TXC2b1

General information and discussion about TeXnicCenter
mdrapk
Posts: 13
Joined: Mon Mar 11, 2013 6:31 pm

Re: Make Yap default DVI Viewer in TXC2b1

Postby mdrapk » Sat Mar 23, 2013 6:10 am

I hinted at the reason in my post - I'm not entirely sure which of the many things I did solved my problem and I didn't want to consume people's time with stuff that might not work. But perhaps you're right - I will share what (I think) I know in good faith and if it helps someone, great.

Let me back up a little. I mentioned this in my original post but I didn't realize it might be part of the answer. I had installed an evaluation copy of PCTeX just to see whether I thought I could work with TeX. I was impressed, but then came across (free and very capable TxC) I installed both MikTeX and TxC alongside the active eval copy of PCTeX. Happy with TxC, I then uninstalled PCTeX. However, components of it clearly stayed around in the Program Files directory and in the registry, particularly in the registry (I found this out by accident - TxC seemed to be using some PCTeX files/directories). (This is beginning to sound ridiculous, but ...) That caused a good deal of confusion in trying to solve my other problem - the default browser for .dvi files.

I mention that because it may have been the genesis of my problems. I think that Win 7 was not able to bind yap to the .dvi filetype for TxC because PCTeX had already bound it to something else, perhaps a proprietary viewer.

Having uninstalled PCTeX, I now uninstalled both TxC and MikTeX to start with a clean slate (I assumed). I re-installed MikTeX and TxC. No good. Like PCTeX, both leave traces behind in the registry and the Program Files directory (I think they trust Windows too much). So I uninstalled them again and this time I went through the Program Files directory and the registry and deleted all references. I also, and this may be more important than I know, deleted the entry for .dvi files in the registry, even though it pointed to yap. Then I installed both MikTeX and TxC again and bingo, it works like a charm.

That's all I know. If you can get value from this shambles of steps then I am happy I took the time to spell it out.

Once again, thanks MartinC for staying engaged.
Regards, Tony

Tags:

MartinC
Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Mon Mar 25, 2013 6:04 pm

Thanks, I am sure this could be helpful to other users. But this is a Miktex issue, not TexnicCenter.

mdrapk
Posts: 13
Joined: Mon Mar 11, 2013 6:31 pm

Postby mdrapk » Tue Mar 26, 2013 6:36 am

You may be right about the source of the problem being MikTeX but I offer this up as a counterpoint.

As I noted, both MikTeX and TxC left significant components around after uninstall. What role that played in my particular problem I'm not sure, but it seems that PCTeX, MikTeX, and TxC are not good players when it comes to uninstalling under Windows. And if one is trying to start from a clean slate then that is a problem with all three, it seems to me.

I didn't mention this in my explanation (it was already long-winded), but TxC seemed to be using or relying on components provided by PCTeX - something I discovered when I manually deleted all PCTeX components: TxC complained that it couldn't find certain PCTeX files. Maybe it's supposed to work that way but it gave no indication of that at install or later.

All of that said, I am not the expert here and do not wish to contest your conclusion. I am just inherently nervous of very definitive statements, especially if they are based on my shambling explanation.

kokocko
Posts: 1
Joined: Thu Jun 20, 2013 9:47 am

Postby kokocko » Thu Jun 20, 2013 9:54 am

Could You tell us what was the problem?

I have the same annoying problem. However, I installed Miktex2.9 after long using MikTex2.8. I redefined my Texmaker. For the moment I have two yap.exe files. It seems the yap from 2.8 is default and the new one from 2.9 is not. Even if I change it manually in Windows 7, Latex still recognise the old yap as default. I don't know how to force the new yap to make default under MikTex. I can change the yap path to old, but I don't want that. I would like to delete the old version, therefore I prefer to find sure solution.

abrown
Posts: 1
Joined: Mon Jul 29, 2013 8:05 pm

Postby abrown » Mon Jul 29, 2013 8:12 pm

I have found the solution to this problem and I thought it might be worthwhile posting it.
The problem is in fact with yap.
All you need to do to fix it is to uncheck the DVI file box in the advanced tab under View->Options

jesusmora
Posts: 1
Joined: Wed Nov 12, 2014 12:16 am

Postby jesusmora » Wed Nov 12, 2014 12:26 am

I had recently the same problem and I solved with this in Windows 8.1:

1.- Simply open TexnicCenter as Administrator (right click TexnicCenter icon and select "Run as Administrator").
2.- Take some latex document and select "Build and View Output" in order to generate the DVI and open it.
3.- When promted, select YAP as default viewer.
4.- Close YAP.
5.- Repeat this process and this time Windows will automatically detect YAP as default and forget that messagebox forever.

Enjoy.


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest