LaTeX forum ⇒ GeneralTeXnicCenter does not invoke BibTeX

General information and discussion about TeXnicCenter
christophk
Posts: 4
Joined: Thu Mar 08, 2007 9:52 pm

TeXnicCenter does not invoke BibTeX

Postby christophk » Thu Mar 08, 2007 10:48 pm

I just installed current MikTeX and TeXnicCenter on a new machine. I tried to complile an old document.

TeXnicCenter does not seem to call BibTeX although that is selected in the settings (I am using the default profile). BibTeX does not show up in the log and I am stuck with all the warnings of undefined citations.
However BibTeX by itself works. I invoked it by hand and it did compile fine.

What am I doing wrong? I have checked the settings and everything looks fine. The path to bibtex.exe is correct, the parameter is (with the quotes).

I have searched the forums and could not find this error nowhere. I am out of ideas.

User avatar
Void
Posts: 11
Joined: Mon Mar 12, 2007 3:00 pm

Postby Void » Mon Mar 12, 2007 3:34 pm

Perhaps you did not handle it as a project. Opening a single file and compiling it invokes only (pdf)latex.

Create a new project and check under features "uses bibtex" and, if it is true, "uses makeindex".

Then

Under project --> properties declare the "main file" ( or "Hauptdatei", if you are using the german version).

I hope, this is helpful.
No or not enough coffee, user halted.

christophk
Posts: 4
Joined: Thu Mar 08, 2007 9:52 pm

Postby christophk » Mon Mar 12, 2007 7:40 pm

Yes, that did the trick. Thanks!

I even *knew* about this option. The problem with TeX is not that the learning curve is so steep, it's that the forgetting curve is even steeper...

reffell
Posts: 10
Joined: Tue Mar 20, 2007 12:52 pm

Postby reffell » Tue Mar 20, 2007 1:02 pm

I'm experiencing the same problem as previously mentioned, so I tried the previous solution and it didn't work for me.

But let me be more clear, I am using natbib (- which when used on its own is fine,) together with multibib - multiple bibliographies for multiple jurisdictions. I simply cannot get bibtex to compile. I have checked all relevant files are in the right place. I know the code is right because I got it from the author of multibib, I set it up as a new project, enabled the bibtex box. Run latex, and bibtex x5, once for each individual bibliography and latex twice more and zip, nothing.

I can get the .aux files, but no .bbl files!

I am an everything nubee, latex, texnic, bibtex and anything tex in fact, so I totally understand it could be a simple solution and I've totally overlooked the obvious - can someone HELP.

christophk
Posts: 4
Joined: Thu Mar 08, 2007 9:52 pm

Postby christophk » Tue Mar 20, 2007 2:37 pm

Try to invoke bibtex by commandline not via TeXnicCenter and see what it returns:

That's something like

  1. "C:\Program Files\MiKTeX\miktex\bin\bibtex.exe" <basefile>


in the dos box when you are in the directory where your tex file is, where <basefile> is the name of your root tex file (the one with \begin{document} in it).
You might need to adapt the path to bibtex.exe

reffell
Posts: 10
Joined: Tue Mar 20, 2007 12:52 pm

Postby reffell » Wed Mar 21, 2007 1:30 am

Thanks for the suggestion, but it didn't work. I double checked the path was going to bibtex.exe - which it was. Then in the dos box I wrote the following <basefile> and I got the following response

  1. I couldn't open file name '<Testagain>.aux'


So I double checked that Testagain.aux was there and it was. I feel like something is disabled or the paths aren't connecting - just how I feel most of the time. Shocked Hummmmmm!

I can still get a single bibliography, which I assume is working from natbib, just not multiple bibliographies which would be created via multibib.

christophk
Posts: 4
Joined: Thu Mar 08, 2007 9:52 pm

Postby christophk » Wed Mar 21, 2007 10:56 am

Um, without the "<>" that was just my stupid kind of syntax.

So it would be:

  1. "C:\Program Files\MiKTeX\miktex\bin\bibtex.exe" Testagain

reffell
Posts: 10
Joined: Tue Mar 20, 2007 12:52 pm

Postby reffell » Wed Mar 21, 2007 12:24 pm

hey thanks, but that didn't work either! - It's a mystery.

ginegine
Posts: 2
Joined: Wed Sep 14, 2011 11:22 am

Postby ginegine » Wed Apr 18, 2012 2:51 pm

Hi there,
I have the same problem as christophk; I installed miktex-2.9.4407 and TXCSetup_2Alpha3, and now when I compile an old .tex file it does not connect to the .bib file.

I handle the file as a project, and I have changed the command line arguments to pass to BibTex to "%tm", but it still does not work.

I use natbib, not multibib.

Unfortunately I dont understand the comment of christophk to invoke bibtex by a commandline... :cry:

The error messages I get are these "I was expecting a `,' or a `}'" - however I know that this .bib file compiled well on a different computer! :shock: is there a problem with the new version of miktex / texniccenter? Is it now impossible to "block out" something by using "%" in the .bib file?

THANKS for your help!! :)


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest