LaTeX forum ⇒ Texmaker and TeXstudioMissing highlighted area in pdf view after “quick build" Topic is solved

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
unpix
Posts: 2
Joined: Fri Feb 14, 2014 2:04 pm

Missing highlighted area in pdf view after “quick build"

Postby unpix » Thu Jun 19, 2014 10:09 pm

One of the greatest things on TeXmaker is that it highlights the area (red rectangle) in the pdf document after running some compilation command. It highlights the block or paragraph or equation, in which the cursor in the tex file is currently located. This is very efficient in correcting some minor misprints. I like this feature the most. Actually, I use TeXmaker because of it.
But, suddenly it doesn't work. I don't know why. I tried to reinstall it, but it was useless. Does anybody know where the problem is? I use the Windows-version of TeXmaker.

Tags:

unpix
Posts: 2
Joined: Fri Feb 14, 2014 2:04 pm

Postby unpix » Fri Jun 20, 2014 12:58 pm

Well, the problem is solved. It was just that the command pdflatex was launch without the switch -syntex.

Kaspolesen
Posts: 1
Joined: Sun Oct 11, 2015 10:16 am

Postby Kaspolesen » Sun Oct 11, 2015 10:18 am

Hi
I encountered the same problem and this post was the only one I could find about it.
But I don't completely understand how you fixed it. Did you write something in the pdflatex command line?
I am using texmaker and completely new

User avatar
Stefan Kottwitz
Site Admin
Posts: 8206
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Sun Oct 11, 2015 11:22 am

Hi Kaspolesen,

welcome to the forum!

The option is called -synctex=1 (there's a typo on the post above). It's a command line option, but you can configure it in your editor settings. Go to "Configure TeXmaker" in the main menu, take a look at those settings and make the same for pdfLaTeX in your editor:

texmaker.png
texmaker.png (53.15 KiB) Viewed 2327 times


Stefan
Site admin

Supercheese
Posts: 1
Joined: Mon Apr 10, 2017 5:44 pm

Postby Supercheese » Mon Apr 10, 2017 5:48 pm

The problem is that the path of your work folders must not contain spaces or special characters. I had the same problem, but I also had the correct settings explained above. Blanck spaces be damned!!!! Hope it helps :-)


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 1 guest