LaTeX forum ⇒ KileProblem with cyrillic

Information and discussion about Kile, an integrated LaTeX environment for Linux KDE
Bozhidar
Posts: 1
Joined: Wed Nov 12, 2014 7:01 pm

Problem with cyrillic

Postby Bozhidar » Wed Nov 12, 2014 7:11 pm

Hello,

I have to translate a paper in Bulgarian. I am on Windows 8 and have Kile editor and MikTex installed.
Unfortunatelly when i write the packages for cyrillic i got nothing. Sometimes it translates the content menu with babel but does not recognize my characters and can not convert them. It wants to use not LaTex to pdf to compile but XeLatex and LulaTex(if i am not wrong with the name).
I have arrange my MikTex for cyrillic already and was able to make TeXnicCenter works with the same code i use in Kile. With TeXnicCenter it works just fine... but i dont like the editor at all...

I use
  1. \documentclass{article}
  2. \usepackage[utf8]{inputenc} --> also cp1251(that is recommended but didnt work)
  3. \usepackage[T2A,T1]{fontenc} ---> tried with only on of them, or change places with the inputenc
  4. \usepackage[bulgarian]{babel}


I would be glad to get some ideas what can i do ? :)
Thanks!
Bozhidar

User avatar
Johannes_B
Site Moderator
Posts: 3548
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Nov 12, 2014 7:35 pm

The important thing is the input encoding, the option you give to package inputenc has to match the encoding your editor saves the files in. You can change it in the properties i guess (make sure to make a backup first).
Recommended encoding is utf8.

That way, you can easily change to LuaLaTeX or XeLaTeX later, if you want to.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “Kile”

Who is online

Users browsing this forum: No registered users and 2 guests