LaTeX forum ⇒ LyXCompiling Error ! Bad mathchar (32768) Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
TiredHornet
Posts: 2
Joined: Thu Feb 23, 2017 2:44 pm

Compiling Error ! Bad mathchar (32768)

Postby TiredHornet » Thu Feb 23, 2017 2:58 pm

Hi,

I am having some trouble compiling an article in LyX. I get the errors:

!Bad mathchar (32768)
! Missing number, treated as zero.
! Missing number, treated as zero.


The bad mathcar error has the following message in the log file:

"A mathchar number must be between 0 and 32767.
I changed this one to zero."

Missing number has this message:

"A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)"

I was able to narrow the problem down to either the table I input into LyX or the math formulas I use. I created a minimal working example, which I attached below. When I compile this LyX file I get the errors. If I remove either one of the equations or the table everything is fine. Can someone tell me what I am doing wrong?

Best regards,
TiredHornet
Attachments
MWE_Bad_Mathchar.lyx
(5.37 KiB) Downloaded 10 times
Ins_Table_Main_Results.tex
(174 Bytes) Downloaded 12 times
Fra_Table_Main_Results.tex
(856 Bytes) Downloaded 9 times

Tags:

roby92ita
Posts: 10
Joined: Mon Feb 13, 2017 11:32 am

Postby roby92ita » Thu Feb 23, 2017 4:25 pm

Hi,
try put this in the preamble:
  1. \usepackage{mathpazo}
  2. \usepackage[mathpazo]{flexisym}

TiredHornet
Posts: 2
Joined: Thu Feb 23, 2017 2:44 pm

Postby TiredHornet » Thu Feb 23, 2017 5:35 pm

Hi roby92ita,

this actually worked. Thank you! So what exactly was the problem here? A missing font for the math stuff?

Best,
TiredHornet

roby92ita
Posts: 10
Joined: Mon Feb 13, 2017 11:32 am

Postby roby92ita » Thu Feb 23, 2017 6:08 pm

You're welcome!
Actually searching for that error I found this on a forum:
"It has nothing to do with the specific table used but the fact that the table may contain math characters or somehow messes with the way LyX deals with math characters inside tex code."
So I thought that using a package for math symbols could help and it worked for your example, but I'm not sure what exactly the problem was.
Try looking in breqn for more details.


Return to “LyX”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests