LaTeX forum ⇒ LyXRestoring the default bind file in LyX Topic is solved

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
Marcelo
Posts: 3
Joined: Mon Oct 01, 2012 10:24 am

Restoring the default bind file in LyX

Postby Marcelo » Mon Oct 01, 2012 10:36 am

Hi

I'm just starting using Lyx and latex at all.

I was setting shortcuts and accidentally pressed 'reconfigure' in 'tools' menu. Then Lyx seemed to have lost a bind file associated and ignored the most typical shortcuts, like Ctrl+s for saving.

Could you tell me how to restore the default, cause I tryed many bind files and I don't have the shortcuts back?

Thanks.
M.

scottkosty
Site Moderator
Posts: 497
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Mon Oct 01, 2012 10:42 am

Marcelo wrote:Hi

I'm just starting using Lyx and latex at all.

I was setting shortcuts and accidentally pressed 'reconfigure' in 'tools' menu. Then Lyx seemed to have lost a bind file associated and ignored the most typical shortcuts, like Ctrl+s for saving.

Could you tell me how to restore the default, cause I tryed many bind files and I don't have the shortcuts back?

Thanks.
M.


Hi Marcelo, welcome to the forums!

Please always try to include your operating system version and LyX version in your questions.

First, make sure you have everything backed up. Then, you could try the following:

1. Open LyX and go to About LyX. Write down your User directory (this should be copyable in the next version).
2. Exit LyX
3. Navigate to where your User directory is and delete it (actully, just move it so that you can restore it if necessary).
4. Restart LyX

Any luck?

Scott

Marcelo
Posts: 3
Joined: Mon Oct 01, 2012 10:24 am

Postby Marcelo » Mon Oct 01, 2012 11:03 am

Sorry, I'm a Debian Wheezy user and my Lyx version is 2.0.3.
Your tip worked perfectly and I have my shorcuts back.

Thanks so much for the quick answer and the welcome.

scottkosty
Site Moderator
Posts: 497
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Mon Oct 01, 2012 11:14 am

Marcelo wrote:Sorry, I'm a Debian Wheezy user and my Lyx version is 2.0.3.
Your tip worked perfectly and I have my shorcuts back.

Thanks so much for the quick answer and the welcome.


Great, thanks for confirming that it's fixed. I think you can mark this thread as solved.

Marcelo
Posts: 3
Joined: Mon Oct 01, 2012 10:24 am

Postby Marcelo » Wed Oct 03, 2012 1:23 am

scottkosty wrote: I think you can mark this thread as solved.


Sorry and thanks for pointing it out. It's been already done by someone else, isn't it? I'm just learning the rules and the interface. Next time for sure.

Best.
M.

scottkosty
Site Moderator
Posts: 497
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Wed Oct 03, 2012 1:49 am

Marcelo wrote:
scottkosty wrote: I think you can mark this thread as solved.


Sorry and thanks for pointing it out. It's been already done by someone else, isn't it?


Yes, you're right.

Marcelo wrote:
I'm just learning the rules and the interface. Next time for sure.

Best.
M.


No need to apologize. I'm still learning the rules and the interface myself :)

laposte
Posts: 1
Joined: Wed Nov 08, 2017 11:18 pm

Postby laposte » Wed Nov 08, 2017 11:40 pm

I had exactly the same problem with my Lyx 2.2 installation
Deleting the Lyx user folder solved the problem
(folder given within: help menu> about lyx, in my case ~\AppData\Roaming\LyX2.2\)
However you loose your preferences and I guess other potentially important information/settings
So finally, I have used another way:
=> I found that the issue was coming from the 'preferences' file in the above mentioned Lyx user folder
I have opened it in a text editor and I have removed the only line mentioning 'bind',
I forget exactly what was exactly this short line, but it was very obvious.
I think the problem arised after I redefined a shortcut (explaining why the preference file added something on bind and the involved shortcut)

scottkosty
Site Moderator
Posts: 497
Joined: Sat Sep 01, 2012 6:38 am

Postby scottkosty » Thu Nov 09, 2017 7:42 am

laposte, do you still have the old original preferences file? I would like to take a look. It's possible we can fix a bug.


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 3 guests