LaTeX forum ⇒ LyXHarvard BibTeX Style — 'et al' not italic in References

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
dexterlemmer
Posts: 2
Joined: Fri Jul 29, 2011 1:08 pm

Harvard BibTeX Style — 'et al' not italic in References

Postby dexterlemmer » Fri Jul 29, 2011 2:00 pm

My references and bibliography should be in the Harvard style. However, in references with many authors, the "et al" part should be in italics (but it isn't).

I'm using LyX v 2.0.0 and MikTeX v 2.9.
I've downloaded the style files (*.bst, for example agsm.bst) from all over and other requirements (such as harvard.sty) was downloaded automatically when LyX/LaTeX/PDFLaTeX/whatever detected they were missing.

I've tried most possible combinations of the following settings:
> Setting 1) Document class: Either article or article(AMS)
> Setting 2) I've also changed the citation style to be one of the following:
2.1) Natbib (Author-year)
2.2) Harvard
> Setting 3) Setting the style as one of the following: agsm, apsr, dcu, kluwer.

To choose setting 2.1:
2.1.1) Document > Settings: Bibliography: Citation Style: Choose Natbib
2.1.2) In the same dialog: Natbib style = Author-year
2.1.3) Document > Settings: LaTeX Preamble: <Empty>

To choose setting 2.2:
2.2.1) Document > Settings: Bibliography: Citation Style: Choose Default
2.2.2) Document > Settings: LaTeX Preamble:
  1. \usepackage{hyperref}
  2. \usepackage{harvard}
  3. \renewcommand{\harvardurl}{URL:\url}


Here is an example of my *.lyx file (with Setting 1= article(AMS), Setting 2=2.1 (Harvard) and Setting3= agsm):
  1. #LyX 2.0 created this file. For more info see http://www.lyx.org/
  2. \lyxformat 413
  3. \begin_document
  4. \begin_header
  5. \textclass amsart
  6. \begin_preamble
  7. %\usepackage{hyperref}
  8. %\usepackage{harvard}
  9. %\renewcommand{\harvardurl}{URL:\url}
  10. \end_preamble
  11. \use_default_options true
  12. \begin_modules
  13. theorems-ams
  14. eqs-within-sections
  15. figs-within-sections
  16. \end_modules
  17. \maintain_unincluded_children false
  18. \language english
  19. \language_package default
  20. \inputencoding auto
  21. \fontencoding global
  22. \font_roman default
  23. \font_sans default
  24. \font_typewriter default
  25. \font_default_family default
  26. \use_non_tex_fonts false
  27. \font_sc false
  28. \font_osf false
  29. \font_sf_scale 100
  30. \font_tt_scale 100
  31.  
  32. \graphics default
  33. \default_output_format default
  34. \output_sync 0
  35. \bibtex_command default
  36. \index_command default
  37. \paperfontsize default
  38. \spacing single
  39. \use_hyperref false
  40. \papersize default
  41. \use_geometry false
  42. \use_amsmath 1
  43. \use_esint 1
  44. \use_mhchem 1
  45. \use_mathdots 1
  46. \cite_engine natbib_authoryear
  47. \use_bibtopic false
  48. \use_indices false
  49. \paperorientation portrait
  50. \suppress_date false
  51. \use_refstyle 1
  52. \index Index
  53. \shortcut idx
  54. \color #008000
  55. \end_index
  56. \secnumdepth 3
  57. \tocdepth 3
  58. \paragraph_separation indent
  59. \paragraph_indentation default
  60. \quotes_language english
  61. \papercolumns 1
  62. \papersides 1
  63. \paperpagestyle default
  64. \tracking_changes false
  65. \output_changes false
  66. \html_math_output 0
  67. \html_css_as_file 0
  68. \html_be_strict false
  69. \end_header
  70.  
  71. \begin_body
  72.  
  73. \begin_layout Section
  74. Section
  75. \end_layout
  76.  
  77. \begin_layout Standard
  78. Testing:
  79. \begin_inset CommandInset citation
  80. LatexCommand citep
  81. key "Delalandre.etal2010"
  82.  
  83. \end_inset
  84.  
  85. .
  86. \end_layout
  87.  
  88. \begin_layout Standard
  89. \begin_inset CommandInset bibtex
  90. LatexCommand bibtex
  91. bibfiles "E:/Documents/Vakke/Meesters/DocumentRecognition/DocumentRecog"
  92. options "E:/Documents/Programs/Programmering/LaTeX/BibTeX/Harvard_PUK/agsm"
  93.  
  94. \end_inset
  95.  
  96.  
  97. \end_layout
  98.  
  99. \end_body
  100. \end_document
  101.  


Here's part of my bibtex file:
  1. % This file was created with JabRef 2.6.
  2. % Encoding: Cp1252
  3.  
  4. @ARTICLE{Delalandre.etal2010,
  5. author = {Mathieu Delalandre and Ernest Valveny and Tony Pridmore and Dimosthenis
  6. Karatzas},
  7. title = {Generation of synthetic documents for performance evaluation of symbol
  8. recognition \& spotting systems},
  9. journal = {International Journal on Document Analysis and Recognition},
  10. year = {2010},
  11. volume = {13},
  12. pages = {187-207},
  13. number = {3},
  14. owner = {Administrator},
  15. timestamp = {2011.05.25},
  16. url = {http://portal.acm.org/citation.cfm?id=1858548}
  17. }

paul
Posts: 49
Joined: Thu Apr 08, 2010 5:56 am

Postby paul » Sat Jul 30, 2011 1:59 am

dexterlemmer wrote:My references and bibliography should be in the Harvard style. However, in references with many authors, the "et al" part should be in italics


Are you sure? The Chicago Manual of Style says it should not be italicized...

dexterlemmer
Posts: 2
Joined: Fri Jul 29, 2011 1:08 pm

Postby dexterlemmer » Thu Aug 04, 2011 11:23 am

Sorry. It seems my university uses a modified version of the Harvard style. At my university, "et al" should be italicized. I've confirmed this with both my study leader and a librarian.

gari
Posts: 1
Joined: Mon Sep 05, 2011 1:09 pm

Postby gari » Mon Sep 05, 2011 1:28 pm

I found this in another forum, I hope it helps:

How to typeset "et al." in italics: Copy the file plainnat.bst (located in the \bibtex\bst\natbib subdirectory of your TeX distribution) into your working directory and rename it to, say, myplainnat.bst. (Later, this file should be placed in your local TEXMF tree). In the renamed copy, search for the string " et~al." * (there should be four instances) and replace every instance with " \emph{et~al.}" *. In your .tex file, use \bibliographystyle{myplainnat}.


Source: http://tex.stackexchange.com/questions/15730/using-natbib-and-plainnat-no-year-appears-to-some-references-and-also-et-al-no

pfeiffer
Posts: 1
Joined: Thu Nov 03, 2011 6:15 pm

Postby pfeiffer » Thu Nov 03, 2011 6:19 pm

Hello,

I found this PDF, maybe it may help!
http://tex.loria.fr/bibdex/harvard.pdf

Cheers,

Michael Pfeiffer

amyfg
Posts: 1
Joined: Mon Nov 28, 2011 11:49 am

Postby amyfg » Mon Nov 28, 2011 11:52 am

Hi,
I know this is an old thread but in case of future searches: I finally got this to work. What you need to do is open the agsm.bst file. For every instance of et~al it needs to be changed to \emph{et~al}. I think there are maybe four instances. Then it will italicise et al in your thesis.

Hope this helps

Amy

Loddi
Posts: 1
Joined: Tue Nov 29, 2011 3:33 am

Postby Loddi » Tue Nov 29, 2011 3:43 am

Hi Latex experts,

thank you for this thread, it helped me a lot in fixing the "et al." issue for my apalike bibtex citation style. However, I have one small problem that is a little bit related to the first one: I would like to have the authors last names in the citation printed in small caps (using the "\scaps{}" command). So that my citations look like this: (OBAMA et al., 2011). I already found the piece of code where things happen:

  1. % There are three apalike cases: one person (Jones),
  2. % two (Jones and de~Bruijn), and more (Jones \emph{et~al.}).
  3. % This function is much like format.crossref.editors.
  4. %
  5. FUNCTION {format.lab.names}
  6. { 's :=
  7. s #1 "{vv~}{ll}" format.name$
  8. s num.names$ duplicate$
  9. #2 >
  10. { pop$ " \emph{et~al.}" * }
  11. { #2 <
  12. 'skip$
  13. { s #2 "{ff }{vv }{ll}{ jj}" format.name$ "others" =
  14. { " \emph{et~al.}" * }
  15. { " \& " * s #2 "{vv~}{ll}" format.name$ * } % " and " -- BJR 10/5/89
  16. if$
  17. }
  18. if$
  19. }
  20. if$
  21. }


but regardless where and what i try to wrap in "\scaps{}", I get errors. I would really appreciate your help.

Thank you very much & kind regards,
Loddi


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 5 guests