LaTeX forum ⇒ OthersHelp with error: XeTeX is required to compile this document Topic is solved

Information and discussion about other TeX distributions not listed above; installation, administration; field reports
Jamwa
Posts: 10
Joined: Mon May 07, 2012 2:56 pm

Help with error: XeTeX is required to compile this document

Postby Jamwa » Tue Oct 16, 2012 2:21 pm

I am fairly experienced with \LaTeX. So I wanted to change the default font and I have Googled around to find out I need to use and fontspec is what is recommended. Here we go:

  1. \documentclass{article}
  2. \usepackage{fontspec}
  3. \usepackage{lipsum}
  4. \setmainfont{Palatino Linotype}
  5. \begin{document}
  6. \lipsum[1-3]
  7. \end{document}



When I try to compile it,

  1. latex test_latex.tex


I get an error, the most glaring of which is

  1. ********************************************
  2. * XeTeX is required to compile this document.
  3. * Sorry!
  4. ********************************************


So I try another (the recommended?) approach but still errors abound:

  1. sh-4.1$ xetex test_latex.tex
  2. This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6)
  3. %&-line parsing enabled.
  4. entering extended mode
  5. (./test_latex.tex
  6. ! Undefined control sequence.
  7. l.1 \documentclass
  8. {article}
  9. ?


What am I doing wrong?
Last edited by cgnieder on Tue Oct 16, 2012 7:54 pm, edited 1 time in total.
Reason: added correct code markup

User avatar
Stefan Kottwitz
Site Admin
Posts: 8451
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue Oct 16, 2012 2:28 pm

Hi Jamwa,

use xelatex,

Stefan
Site admin

Jamwa
Posts: 10
Joined: Mon May 07, 2012 2:56 pm

Postby Jamwa » Tue Oct 16, 2012 2:34 pm

Hi Stefan,

use xelatex


I have just done that and quite a lot of output I get, but still error:

  1. sh-4.1$ xelatex test_latex.tex
  2. This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6)
  3. %&-line parsing enabled.
  4. kpathsea: Running mktexfmt xelatex.fmt
  5. fmtutil: running `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' ...
  6. This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6) (INITEX)
  7. %&-line parsing enabled.
  8. entering extended mode
  9. (/usr/share/texmf/tex/latex/latexconfig/xelatex.ini
  10. (/usr/share/texmf/tex/generic/xetexconfig/unicode-letters.tex)
  11. (/usr/share/texmf/tex/latex/base/latex.ltx
  12. (/usr/share/texmf/tex/latex/base/texsys.cfg)
  13. ./texsys.aux found
  14.  
  15.  
  16. \@currdir set to: ./.
  17.  
  18.  
  19. Assuming \openin and \input
  20. have the same search path.
  21.  
  22.  
  23. Defining UNIX/DOS style filename parser.
  24.  
  25. catcodes, registers, compatibility for TeX 2, parameters,
  26.  
  27. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  28. ! You are attempting to make a LaTeX format from a source file
  29. ! That is more than five years old.
  30. !
  31. ! If you enter <return> to scroll past this message then the format
  32. ! will be built, but please consider obtaining newer source files
  33. ! before continuing to build LaTeX.
  34. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  35.  
  36. ! LaTeX source files more than 5 years old!.
  37. l.545 ...aTeX source files more than 5 years old!}
  38.  
  39. ?
  40. ! Emergency stop.
  41. l.545 ...aTeX source files more than 5 years old!}
  42.  
  43. No pages of output.
  44. Transcript written on xelatex.log.
  45. Error: `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed
  46.  
  47. ###############################################################################
  48. fmtutil: Error! Not all formats have been built successfully.
  49. Visit the log files in directory
  50. /home/arthur/.texlive2007/texmf-var/web2c
  51. for details.
  52. ###############################################################################
  53.  
  54. This is a summary of all `failed' messages and warnings:
  55. `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed
  56. warning: kpathsea: mktexfmt output `This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6) (INITEX)
  57. %&-line parsing enabled.
  58. entering extended mode
  59. (/usr/share/texmf/tex/latex/latexconfig/xelatex.ini
  60. (/usr/share/texmf/tex/generic/xetexconfig/unicode-letters.tex)
  61. (/usr/share/texmf/tex/latex/base/latex.ltx
  62. (/usr/share/texmf/tex/latex/base/texsys.cfg)
  63. ./texsys.aux found
  64.  
  65.  
  66. \@currdir set to: ./.
  67.  
  68.  
  69. Assuming \openin and \input
  70. have the same search path.
  71.  
  72.  
  73. Defining UNIX/DOS style filename parser.
  74.  
  75. catcodes, registers, compatibility for TeX 2, parameters,
  76.  
  77. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  78. ! You are attempting to make a LaTeX format from a source file
  79. ! That is more than five years old.
  80. !
  81. ! If you enter <return> to scroll past this message then the format
  82. ! will be built, but please consider obtaining newer source files
  83. ! before continuing to build LaTeX.
  84. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  85.  
  86. ! LaTeX source files more than 5 years old!.
  87. l.545 ...aTeX source files more than 5 years old!}
  88.  
  89. ?
  90. ! Emergency stop.
  91. l.545 ...aTeX source files more than 5 years old!}
  92.  
  93. No pages of output.
  94. Transcript written on xelatex.log.' instead of a filename.
  95. I can't find the format file `xelatex.fmt'!
  96. sh-4.1$


No PDF file is produced at the end of it all

User avatar
Stefan Kottwitz
Site Admin
Posts: 8451
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue Oct 16, 2012 2:43 pm

That's much better. But did you read the output? You need to update your LaTeX, it's too old.

Stefan
Site admin

Jamwa
Posts: 10
Joined: Mon May 07, 2012 2:56 pm

Postby Jamwa » Tue Oct 16, 2012 2:46 pm

Let me upgrade and I will post the outcome

Jamwa
Posts: 10
Joined: Mon May 07, 2012 2:56 pm

Postby Jamwa » Thu Oct 18, 2012 9:40 am

Thanks Stefan. The code now generates a pdf well:

  1. \documentclass{article}
  2. \usepackage{fontspec}
  3. \usepackage{lipsum}
  4. \setmainfont{Cantarell}
  5. \begin{document}
  6. \lipsum[1-3]
  7. \end{document}
Last edited by cgnieder on Thu Oct 18, 2012 11:16 am, edited 1 time in total.
Reason: inline code changed to code block


Return to “Others”

Who is online

Users browsing this forum: No registered users and 1 guest